Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63831 - gnu-free-fonts causes fop to use wrong fonts; latest ttf-freefont works correctly

Attached to Project: Arch Linux
Opened by Justus Piater (piater) - Wednesday, 18 September 2019, 20:51 GMT
Last edited by Antonio Rojas (arojas) - Sunday, 09 February 2020, 17:20 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

With gnu-free-fonts installed (20120503-6 or -7), fop uses wrong fonts, at least if the FreeSerif family is specified: bold font weight is ignored; oblique is used instead of normal sans-serif, italic instead of serif, and probably more. All of this works correctly if the latest ttf-freefont package is installed instead. I can create a MWE if it helps, but testing in my actual setup is probably easier for both parties.
This task depends upon

Closed by  Antonio Rojas (arojas)
Sunday, 09 February 2020, 17:20 GMT
Reason for closing:  Not a bug
Comment by Justus Piater (piater) - Sunday, 09 February 2020, 11:40 GMT
This appears to be a bug in fop [1]. FWIF, if registering the OTF fonts of this package explicitly with fop [2], the result is correct.

[1] https://issues.apache.org/jira/browse/FOP-2591
[2] https://xmlgraphics.apache.org/fop/2.1/fonts.html#register

Loading...