Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63828 - wireshark-cli missing /usr/include/wireshark/config.h (blocks compilation of libvirt)

Attached to Project: Community Packages
Opened by Jeff Cook (jeffcookio) - Wednesday, 18 September 2019, 17:24 GMT
Last edited by Eli Schwartz (eschwartz) - Thursday, 19 September 2019, 15:48 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

The wireshark-cli package lacks some headers. If the configure script picks up the presence of Wireshark, it tries to build against a header that should be at /usr/include/wireshark/config.h, but this header is not present in either the wireshark-cli or wireshark-qt package.

See these three comments on the AUR package for libvirt-git:
https://aur.archlinux.org/packages/libvirt-git/#comment-701307
https://aur.archlinux.org/packages/libvirt-git/#comment-701256
https://aur.archlinux.org/packages/libvirt-git/#comment-701177

I'm also getting this trying to run makepkg against the PKGBUILD in both community and testing.

The error on my machine is:

```
make[3]: Entering directory '/home/jeff/code/libvirt/src/libvirt-5.6.0/tools'
CCLD libvirt_shell.la
CCLD nss/libnss_libvirt_impl.la
CCLD nss/libnss_libvirt_guest_impl.la
CC wireshark/src/libvirt_la-packet-libvirt.lo
CC wireshark/src/libvirt_la-plugin.lo
wireshark/src/packet-libvirt.c:21:10: fatal error: wireshark/config.h: No such file or directory
21 | #include <wireshark/config.h>
| ^~~~~~~~~~~~~~~~~~~~
compilation terminated.
make[3]: *** [Makefile:2861: wireshark/src/libvirt_la-packet-libvirt.lo] Error 1
make[3]: *** Waiting for unfinished jobs....
wireshark/src/plugin.c:17:10: fatal error: wireshark/config.h: No such file or directory
17 | #include <wireshark/config.h>
| ^~~~~~~~~~~~~~~~~~~~
compilation terminated.
make[3]: *** [Makefile:2868: wireshark/src/libvirt_la-plugin.lo] Error 1
make[3]: Leaving directory '/home/jeff/code/libvirt/src/libvirt-5.6.0/tools'
make[2]: *** [Makefile:2437: all] Error 2
make[2]: Leaving directory '/home/jeff/code/libvirt/src/libvirt-5.6.0/tools'
make[1]: *** [Makefile:2129: all-recursive] Error 1
make[1]: Leaving directory '/home/jeff/code/libvirt/src/libvirt-5.6.0'
make: *** [Makefile:2022: all] Error 2
```

Additional info:
* package version(s): wireshark-cli v3.0.4-1, libvirt v5.6.0-1

Steps to reproduce:
Try to build libvirt on a machine that also has Wireshark installed, observe failure.
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Thursday, 19 September 2019, 15:48 GMT
Reason for closing:  Upstream
Additional comments about closing:  libvirt is broken, report upstream
Comment by Doug Newgard (Scimmia) - Wednesday, 18 September 2019, 17:49 GMT
This is what wireshark is installing by default. If it's supposed to install config.h, wireshark upstream needs to fix it. If it's not supposed to install config.h, libvirt upstream needs to fix it.

Build in a clean chroot and it's not an issue unless you specifically want wireshark support.
Comment by Eli Schwartz (eschwartz) - Thursday, 19 September 2019, 15:47 GMT
  • Field changed: Status (Assigned → Unconfirmed)
  • Field changed: Category (Packages → Upstream Bugs)
  • Assignment removed
Wireshark upstream does not install this file. If you look at their rpm spec file, the rpm development package simply runs the install target, then picks up files from usr/include/wireshark/*
https://code.wireshark.org/review/gitweb?p=wireshark.git;a=blob;f=packaging/rpm/wireshark.spec.in;h=6e600186fb2c445301d19787bfbb32d032a63014;hb=HEAD#l503

Fedora's own packaging does... something homebrew, there: https://src.fedoraproject.org/rpms/wireshark/blob/master/f/wireshark.spec#_146

Since libvirt is sponsored by Red Hat, it makes sense that Red Hat software will be developed against the buggy Red Hat packaging. Please report a libvirt bug. It is definitively not the intention of wireshark to export that config.h header, libvirt must not use it and Red Hat must not distribute it.

Loading...