Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63826 - [gnome-shell] Unable to close the overview when opened in a workspace without windows

Attached to Project: Arch Linux
Opened by Muflone (muflone) - Wednesday, 18 September 2019, 15:29 GMT
Last edited by Antonio Rojas (arojas) - Sunday, 22 September 2019, 08:13 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To No-one
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:

Opening the GNOME Shell overview from a workspace without any opened window there's no way to close the overview, neither by starting applications nor by clicking the activities button or using the hot corner.

This issue is more boring during the first startup as the standard GNOME shell has no icons on the desktop, has no a visible dockbar until I open the overview window and there's no way to start an application without first passing from the overview window (except using ALT+F2)

Under this condition, the 50% of the times the dock bar doesn't appear (see the first 10 seconds of the attached video)
When happens the dock bar appears, the defect is the same, I could open the applications from there but there's still no way to exit from the overview.

This is actually always reproducible for my system using GNOME on Xorg, even without any enabled GNOME Shell extension.
I've two users for my system but this issue happens only in my daily user, while the other works fine with the same configuration.


Additional info:

* gdm 3.34.0-2
* gnome-shell 1:3.34.0+94+g3d86e6e79-1
* linux 5.3.arch1-1 and 5.2.14.arch2-1
* intel video drivers on KMS

Steps to reproduce:

* Start GNOME on Xorg from GDM
* Click the activities text (or move the mouse cursor in the upper left corner)
* The overview appears
* Open any application
* The overview remains opened and there's no way to close it apart by killing it using ALT+F2 -> r
This task depends upon

Closed by  Antonio Rojas (arojas)
Sunday, 22 September 2019, 08:13 GMT
Reason for closing:  Fixed
Comment by Sebastian Pinnau (spinnau) - Thursday, 19 September 2019, 12:26 GMT Comment by Saren Arterius (saren) - Friday, 20 September 2019, 06:21 GMT
Just got hit by this and spent 30 minutes to debug, not autostarting Nemo workarounded this issue.
Also in upstream

```
pezz @pezz ยท 2 hours ago

I also noticed this issue on Arch Linux, however I found the culprit to be anything that provided desktop icons, such as an extension or a file manager like Nemo.

Disabling desktop icons in Nemo lead to proper behaviour.

Edit: @jadbox if you're on X (not Wayland) you can Alt+F2 then type r to restart the shell as a bit of a workaround.
```
Comment by Chris Billington (chrisjbillington) - Friday, 20 September 2019, 13:42 GMT
Looks like a fix has merged upstream as commit 817aec54
Comment by Muflone (muflone) - Saturday, 21 September 2019, 15:06 GMT
In my case the culprit was conky in the background

gnome-shell 1:3.34.0+148+g506b75fc7-1 fixed the issue

Loading...