AUR web interface

**This is the bug tracker for the AUR web interface.**

Use this tracker to report bugs or make feature requests regarding the behaviour or implementation of the AUR software.
Please read the Reporting Bug Guidelines before filing a new task.
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

- Please report bugs related to Arch Linux official packages here: http://bugs.archlinux.org/index.php?project=1
- Please report bugs for [community] packages here: http://bugs.archlinux.org/index.php?project=5
- For any packages in the AUR contact the maintainer or leave a comment on the package's detail page.

Source Code:
https://projects.archlinux.org/aurweb.git/
Tasklist

FS#63808 - AUR register: The entered CAPTCHA answer is invalid

Attached to Project: AUR web interface
Opened by Patrick Ben Koetter (Patrick) - Tuesday, 17 September 2019, 12:50 GMT
Task Type Bug Report
Category Backend
Status Unconfirmed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version 4.7.0
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

I'm unable to register a new account, because the CAPTCHA is always said to be invalid. Seems like something's br0ken, because to me the commadn to calculate the CAPTCHA is valid. See also: The attached CAPTCHA dialogie showing an error)
   captcha.png (155.6 KiB)
This task depends upon

Comment by Eli Schwartz (eschwartz) - Tuesday, 17 September 2019, 13:19 GMT
What is the output of

pacman -V

When I run the specified command, I get a different result from you:

$ pacman -V|sed -r 's#[0-9]+#c65#g'|md5sum|cut -c1-6
56ad1b

(No, this result won't work, since the sed replacement regularly changes.)
Comment by Doug Newgard (Scimmia) - Tuesday, 17 September 2019, 13:32 GMT
everything looks fine to me, you have the wrong answer
Comment by Eli Schwartz (eschwartz) - Tuesday, 17 September 2019, 14:16 GMT
To clarify why I am asking, the current captcha doesn't care what your version of pacman is, but it does require that pacman is not built with --enable-git-version (so, using pacman-git from the AUR would yield the wrong results).

My pacman-git build does not produce the *same* incorrect answer as you, so if you are using pacman-git you're not using the same build as me.
Comment by Patrick Ben Koetter (Patrick) - Tuesday, 17 September 2019, 14:20 GMT
The output of "pacman -V" is:

$ pacman -V

.--. Pacman v5.1.3 - libalpm v11.0.3
/ _.-' .-. .-. .-. Copyright (C) 2006-2018 Pacman Development Team
\ '-. '-' '-' '-' Copyright (C) 2002-2006 Judd Vinet
'--'
Dieses Programm darf unter Bedingungen der GNU
General Public License frei weiterverbreitet werden.
Comment by Eli Schwartz (eschwartz) - Tuesday, 17 September 2019, 14:21 GMT
Aha, try LC_ALL=C ;)
Comment by Patrick Ben Koetter (Patrick) - Tuesday, 17 September 2019, 14:37 GMT
Got it! It seems your CAPTCHA generator assumes LANG has been set to en_EN.UTF8:

[p@p ~]$ export LANG=en_EN.UTF8
[p@p ~]$ pacman -V

.--. Pacman v5.1.3 - libalpm v11.0.3
/ _.-' .-. .-. .-. Copyright (C) 2006-2018 Pacman Development Team
\ '-. '-' '-' '-' Copyright (C) 2002-2006 Judd Vinet
'--'
This program may be freely redistributed under
the terms of the GNU General Public License.

[p@p ~]$ pacman -V|sed -r 's#[0-9]+#c65#g'|md5sum|cut -c1-6
56ad1b
Comment by Patrick Ben Koetter (Patrick) - Tuesday, 17 September 2019, 15:11 GMT
I believe the captcha generator should at least mention that LC_ALL=C is required.
Comment by Eli Schwartz (eschwartz) - Tuesday, 17 September 2019, 15:12 GMT

Loading...