Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63782 - [gnuradio-companion] should depend on python-gobject

Attached to Project: Community Packages
Opened by Peter Tirsek (tirsek) - Sunday, 15 September 2019, 22:49 GMT
Last edited by Muflone (muflone) - Saturday, 26 September 2020, 21:40 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Kyle Keen (keenerd)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
gnuradio-companion fails with a cryptic error message when python-gobject is not installed:

```
$ gnuradio-companion
Traceback (most recent call last):
File "/usr/bin/gnuradio-companion", line 59, in check_gtk
gi.require_version('Gtk', '3.0')
AttributeError: module 'gi' has no attribute 'require_version'

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File "/usr/bin/gnuradio-companion", line 100, in <module>
check_gtk()
File "/usr/bin/gnuradio-companion", line 67, in check_gtk
die(err, "Failed to initialize GTK. If you are running over ssh, "
File "/usr/bin/gnuradio-companion", line 41, in die
gi.require_version('Gtk', '3.0')
AttributeError: module 'gi' has no attribute 'require_version'
```

After installing python-gobject, the program runs as expected.

python-gobject should be moved from makedepends to depends in PKGBUILD.

Additional info:
* package version(s): gnuradio-companion 3.8.0.0-2
This task depends upon

Closed by  Muflone (muflone)
Saturday, 26 September 2020, 21:40 GMT
Reason for closing:  Fixed
Additional comments about closing:  fixed in gnuradio-companion 3.8.1.0-3
Comment by Roman Blanco (rblanco) - Monday, 27 January 2020, 21:32 GMT
GNU Radio Companion 3.8.0.0 needs python-cairo-1.18.2-3 as well.

Same issue as described here happens otherwise:
https://github.com/rbgirshick/py-faster-rcnn/issues/221#issuecomment-407926248

Loading...