Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63775 - [opera] unable to find widevine binaries

Attached to Project: Community Packages
Opened by Alfin Bakhtiar Ilhami (alfin) - Sunday, 15 September 2019, 12:17 GMT
Last edited by Ike Devolder (BlackEagle) - Sunday, 06 October 2019, 09:15 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Ike Devolder (BlackEagle)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
unable to open copyright protected content because opera unable to find widevine binaries. widevine can be installed from aur chromium-widevine, the binaries is located in:
- /usr/lib/chromium-dev/libwidevinecdm.so
- /usr/lib/chromium/libwidevinecdm.so
but /usr/lib/opera/resources/widevine_config.json does not contain any of these...

$ cat /usr/lib/opera/resources/widevine_config.json
[
{
"preload" : "/opt/google/chrome/libwidevinecdm.so"
},
{
"preload" : "/opt/google/chrome-beta/libwidevinecdm.so"
},
{
"preload" : "/opt/google/chrome-unstable/libwidevinecdm.so"
}
]

Additional info:
* package version(s) : 63.0.3368.88-1
* config and/or log files etc. : /usr/lib/opera/resources/widevine_config.json

Steps to reproduce:
open opera and start playing copyright protected content like netflix or spotify
This task depends upon

Closed by  Ike Devolder (BlackEagle)
Sunday, 06 October 2019, 09:15 GMT
Reason for closing:  Upstream
Additional comments about closing:  reported upstream
Comment by Ike Devolder (BlackEagle) - Sunday, 06 October 2019, 09:15 GMT
upstream issue: DNA-81478

Loading...