Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63762 - [nautilus] fail when trying to generate thumbnails with linux-hardened

Attached to Project: Arch Linux
Opened by Lamb Maerten (Lamb) - Saturday, 14 September 2019, 14:06 GMT
Last edited by Jan de Groot (JGC) - Sunday, 15 September 2019, 13:45 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

DescriptionI:
Nautilus in it's current state fails when trying to generate thumbnails with linux-hardened.
After some digging, I managed to fix it by reactivating unprivileged user namespaces :
$ sysctl -w kernel.unprivileged_userns_clone=1

Additional info:
* 3.32.3-1
* works flawlessly with Thunar & Ristretto
* probably due to nautilus use the use of bwrap

Steps to reproduce:
0. 4. sudo sysctl -w kernel.unprivileged_userns_clone=0
1. empty ~/.cache/thumbnails
2. open a directory with nautilus with pictures
3. all thumbnails end up in ~/.cache/thumbnails/fail
4. sudo sysctl -w kernel.unprivileged_userns_clone=1
5. repeat step 1 & 2
6. all thumbnails are correctly generated
This task depends upon

Closed by  Jan de Groot (JGC)
Sunday, 15 September 2019, 13:45 GMT
Reason for closing:  Not a bug
Comment by Jan de Groot (JGC) - Sunday, 15 September 2019, 13:45 GMT
bubblewrap needs user namespaces. If your kernel doesn't support it, install bubblewrap-suid instead.

Loading...