Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63758 - [otf-fira-code] Version 2-1 not usable in some applications (e.g. Kitty terminal).

Attached to Project: Community Packages
Opened by Joel (Kage-Yami) - Saturday, 14 September 2019, 09:39 GMT
Last edited by freswa (frederik) - Tuesday, 11 February 2020, 21:57 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Jiachen Yang (farseerfc)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

It seems the new version 2-1 of this package is no longer usable in some other applications.
For example, despite setting "Fira Code" as the desired font in Kitty terminal, it still falls back to some other font.

An example of someone else experiencing this: https://www.reddit.com/r/archlinux/comments/d3reo4/fira_codes_font_ligatures_suddenly_stopped/

(Note, this issue also is apparent with the ttf version).
This task depends upon

Closed by  freswa (frederik)
Tuesday, 11 February 2020, 21:57 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Not a font bug, but application related
Comment by Wil Thomason (wbthomason) - Saturday, 14 September 2019, 18:00 GMT
There's a relevant issue on the Fira Code repository: https://github.com/tonsky/FiraCode/issues/840

In particular, the following comment has a fix: https://github.com/tonsky/FiraCode/issues/840#issuecomment-531471498. This resolves the problem with Kitty, at the least (I have not tested other applications that may have broken with the new release).

It's not yet clear if the Fira Code repository will add the `/etc/fonts/conf.d/80-firacode-spacing.conf` file as suggested by the linked comment. If it doesn't, perhaps this file could be added to the Arch `otf-fira-code` and `ttf-fira-code` packages?
Comment by Luflosi (Luflosi) - Thursday, 19 September 2019, 19:31 GMT
This has since been fixed in kitty, see https://github.com/kovidgoyal/kitty/issues/1968. kitty is now able to use fonts with spacing=90.
Until a new version is released you'll either have to use the git version from the AUR or use the workaround mentioned above.
Comment by Joel (Kage-Yami) - Friday, 20 September 2019, 08:15 GMT
Thanks for pointing out it's since been fixed on the kitty side - I've switched to kitty-git for now, and all happy. :)
Comment by Joel (Kage-Yami) - Wednesday, 25 September 2019, 07:44 GMT
Looks like kitty in the Arch repositories has been updated to resolve this issue now.

Loading...