Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63755 - [pulseaudio] 12.99.3-1 tcp tunnel sink is not recognized correctly

Attached to Project: Arch Linux
Opened by Random (random237849) - Saturday, 14 September 2019, 08:26 GMT
Last edited by Jan Alexander Steffens (heftig) - Sunday, 15 September 2019, 12:04 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

since the upgrade to pulseaudio 12.99.3-1 a remote native tcp sink is not recognized correctly.
the remote server is somehow detected, but the client produces a "Failed to parse module arguments" error.

the following messages are logged on the client:

D: [pulseaudio] module-zeroconf-discover.c: Loading module-tunnel-sink with arguments 'server=[XXXXXX]:4713 sink=alsa_output.XXXXXXX.stereo-fallback format=s16le channels=2 rate=44100 sink_properties=device.icon_name=computer sink_name=tunnel.XXXXX.local.alsa_output.XXXXXXX.stereo-fallback channel_map=front-left,front-right'
E: [pulseaudio] module-tunnel.c: Failed to parse module arguments
E: [pulseaudio] module.c: Failed to load module "module-tunnel-sink" (argument: "server=[XXXXXXXXXXX]:4713 sink=alsa_output.XXXXXXXX.stereo-fallback format=s16le channels=2 rate=44100 sink_properties=device.icon_name=computer sink_name=tunnel.XXXXXX.local.alsa_output.XXXXXXXXXX.stereo-fallback channel_map=front-left,front-right"): initialization failed.

on the client "pactl list sinks" does not show the remote sink.
no errors are logged on the server.

btw: pulseaudio 13.0 is out since a couple of days. it might be the problem is fixed with 13.0. ;)
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Sunday, 15 September 2019, 12:04 GMT
Reason for closing:  Fixed
Additional comments about closing:  pulseaudio 13.0-2
Comment by Random (random237849) - Saturday, 14 September 2019, 08:49 GMT
i just installed the pulseaudio-git package from AUR on the client.
the sink (which is still mainline 12.99.3-1) is now detected correctly and sound over tcp is working again.
Comment by Random (random237849) - Sunday, 15 September 2019, 11:27 GMT
pulseaudio 13.0-1 was released on arch. the problem persisits: "Failed to parse module arguments"
however, with the aur packages on the client (and the 13.0-1 mainline version on the server) the module arguments get parsed correctly and tcp tunnel works.
is this a bug in the arch packages, or an upstream problem?
Comment by Jan Alexander Steffens (heftig) - Sunday, 15 September 2019, 12:04 GMT

Loading...