Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63720 - [shaderc] missing symbol _ZN7glslang8TProgram5ma

Attached to Project: Arch Linux
Opened by John Bug (johnbug) - Wednesday, 11 September 2019, 14:05 GMT
Last edited by Sven-Hendrik Haase (Svenstaro) - Wednesday, 11 September 2019, 18:22 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Sven-Hendrik Haase (Svenstaro)
Maxime Gauduin (Alucryd)
Levente Polyak (anthraxx)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 11
Private No

Details

Description:
mpv does not start and shows the following error:

symbol lookup error: /usr/lib/libshaderc_shared.so.1: undefined symbol: _ZN7glslang8TProgram5mapIOEPNS_14TIoMapResolverE

Additional info:
* mpv-1:0.29.1-8
* shaderc 2019.0-1
* linux-lts 4.19.72-1
This task depends upon

Closed by  Sven-Hendrik Haase (Svenstaro)
Wednesday, 11 September 2019, 18:22 GMT
Reason for closing:  Fixed
Comment by Eli Schwartz (eschwartz) - Wednesday, 11 September 2019, 14:21 GMT
  • Field changed: Attached to Project (Community Packages → Arch Linux)
  • Field changed: Summary (mpv: symbol lookup error: /usr/lib/libshaderc_shared.so.1: undefined symbol: _ZN7glslang8TProgram5ma → [shaderc] missing symbol _ZN7glslang8TProgram5ma)
  • Field changed: Status (Unconfirmed → Assigned)
  • Field changed: Severity (Low → High)
  • Task assigned to Sven-Hendrik Haase (Svenstaro)
libshaderc_shared.so is also used by dav1dplay, which manifests the same issue. The problem is that glslang was updated, and shaderc wasn't rebuilt with it.
Comment by Andres Santamaria (asantam) - Wednesday, 11 September 2019, 14:23 GMT
The culprit of this seems to be the latest glslang update (which shaderc depends on) as suggested by https://bugzilla.opensuse.org/show_bug.cgi?id=1149869.

Downgrading glslang to previous version (7.11.3214-2) seems to solve this for now.
Comment by Levente Polyak (anthraxx) - Wednesday, 11 September 2019, 15:10 GMT
Here is a TODO list for the affected packages:
https://www.archlinux.org/todo/glslang-7123352-1-abi-rebuild/
libplacebo
shaderc
snes9x-gtk

Adding assignees of those packages as well
Comment by CalimeroTeknik (Calimero) - Wednesday, 11 September 2019, 16:55 GMT
For me it was sufficient to rebuild shaderc from the PKGBUILD for mpv to run again.
That doesn't mean it's a proper solution and there isn't still some breakage going on elsewhere; it's a hack for users who are in a hurry to get their video player running.
Comment by Sven-Hendrik Haase (Svenstaro) - Wednesday, 11 September 2019, 17:48 GMT
Fuck me, sorry guys. glslang never has soname changes so it's hard to tell if it's going to break. I'm going to put a note into the package.

Loading...