Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63704 - [systemd][sysusers]: All users created by systemd-sysusers are expired

Attached to Project: Arch Linux
Opened by Tobias Hunger (hunger) - Monday, 09 September 2019, 15:04 GMT
Last edited by Antonio Rojas (arojas) - Monday, 09 September 2019, 17:21 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
All system accounts created by systemd-sysusers are expired. This will break any fresh installation of Arch Linux.

The effects of this vary, but one annoying one is that gdm will no longer start since its user is expired.

Additional info:
* systemd 243.0-1

Steps to reproduce:
* Do a pacstrap install into a directory
* chage --root=/path/to/pacstrap/root -l bin.
* "Account expires" gives a date of 2nd of Jan. 1970.

Steps to fix:
* Run "chage -E -1 <account>" once for all system accounts listed in lines starting with "u" in /usr/lib/sysusers.d/*
This task depends upon

Closed by  Antonio Rojas (arojas)
Monday, 09 September 2019, 17:21 GMT
Reason for closing:  Not a bug
Comment by Tobias Hunger (hunger) - Monday, 09 September 2019, 15:12 GMT
A fresh pacstrap installation build with systemd 242.84-2 does show all systemd-sysusers created with "Account expires: never".
Comment by nl6720 (nl6720) - Monday, 09 September 2019, 15:33 GMT
This is an intentional change in systemd 243. See https://github.com/systemd/systemd/pull/13277 .
Comment by Tobias Hunger (hunger) - Monday, 09 September 2019, 16:22 GMT
*sigh*

There does not seem to be a way to opt out of this behaviour again via systemd-sysusers configuration files:-(

So this bug should be moved over to gdm to ask them not to use sysusers anymore:-(
Comment by Tobias Hunger (hunger) - Monday, 09 September 2019, 16:57 GMT
I opened  FS#63706  against gdm. Let's close this one.

Loading...