Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63685 - [linux-hardened] archiso fails to build because of a mount error

Attached to Project: Arch Linux
Opened by notaspamaccount123 (notaspamaccount123) - Sunday, 08 September 2019, 00:43 GMT
Last edited by freswa (frederik) - Saturday, 22 February 2020, 16:18 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Archiso fails to build on the linux-hardened kernel with the releng config. Switching to the vanilla Linux kernel worked. Building worked fine a few weeks ago so a recent update must have caused it.

It fails with an error message saying "mount: work/efiboot: mount failed: Operation not permitted.".

Attempting to replicate the issue manually by running "mount /home/user/archlive/work/iso/EFI/archiso/efiboot.img /home/user/archlive/work/efiboot" also failed.

I have not yet tested this with the baseline config.

Additional info:
* linux-hardened 5.2.11.a-1
* linux-hardened-headers 5.2.11.a-1
* archiso 42-1
* possibly related to https://bugs.archlinux.org/task/63508

Steps to reproduce:
1. Install and boot the linux-hardened kernel
2. Build archiso with the releng config as described on the wiki - https://wiki.archlinux.org/index.php/Archiso
3. The build will fail
This task depends upon

Closed by  freswa (frederik)
Saturday, 22 February 2020, 16:18 GMT
Reason for closing:  None
Additional comments about closing:  This seems pretty stalled to me. If it's still an issue, please fill a re-open request. Thank you :)

Loading...