Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63676 - [libu2f-host] Specified group 'plugdev' unknown, bug from upstream.

Attached to Project: Community Packages
Opened by Milutin Jovanović (mikijov) - Friday, 06 September 2019, 23:13 GMT
Last edited by Christian Hesse (eworm) - Monday, 04 November 2019, 14:52 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Christian Hesse (eworm)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

libu2f-host uses non-existent group 'plugdev' in 70-u2f.rules.

Additional info:

Package Version: 1.1.10-1

This bug is already tracked in upstream as:
https://github.com/Yubico/libu2f-host/issues/116
However, there has not been any movement for months and no indication it will be fixed there.

Further confirmation and Arch compatible fix was done in another package with the similar problem:
https://bugs.archlinux.org/task/35602

The proposed solution is to replace 'plugdev' with 'users' group.

Suggestion here is to patch the 70-u2f.rules during package build, until the issue is fixed upstream.

Steps to reproduce:
Look for line below in boot log:
Sep 06 18:16:57 voreni-tp1 systemd-udevd[409]: Specified group 'plugdev' unknown
This task depends upon

Closed by  Christian Hesse (eworm)
Monday, 04 November 2019, 14:52 GMT
Reason for closing:  Fixed
Additional comments about closing:  libu2f-host 1.1.10-2
Comment by Michel Koss (MichelKoss1) - Sunday, 08 September 2019, 14:59 GMT
"The proposed solution is to replace 'plugdev' with 'users' group."

This is wrong solution. Arch doesn't support inits other than systemd and systemd doesn't need any static group permissons as it grants them dynamically to logged user. The proper solution is to patch-out "plugdev" group from udev rule.

Loading...