Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#6366 - xorg-server 1.2.0 broken on ATI cards

Attached to Project: Arch Linux
Opened by Jacek Poplawski (Jacek Poplawski) - Wednesday, 07 February 2007, 12:07 GMT
Last edited by Alexander Baldeck (kth5) - Tuesday, 25 September 2007, 15:32 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Alexander Baldeck (kth5)
Architecture All
Severity Low
Priority Normal
Reported Version 0.7.2 Gimmick
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I installed xorg-server 1.2.0 from the testing repository.
I was able to start X, and everything was working, but very, very slowly.
I looked into top and realized that X process eats lots of CPU.
This is confirmed by another person in this thread:
http://bbs.archlinux.org/viewtopic.php?id=29661
This is probably related to open source ATI Radeon driver.
My system:
- latest stuff from current repository and testing repository
- Athlon 3000+
- Radeon 9800 Pro using DRI driver
- kernel 2.6.20 from testing
This task depends upon

Closed by  Alexander Baldeck (kth5)
Tuesday, 25 September 2007, 15:32 GMT
Reason for closing:  Deferred
Additional comments about closing:  xorg-server 1.2.0 is will be obsoleted soon
Comment by Bill Walsh (badger) - Wednesday, 07 February 2007, 21:53 GMT
Not sure if this is tha eaxact same issue (different symptoms), similar to lumiwa in this thread: http://bbs.archlinux.org/viewtopic.php?id=29650 upgrading to kernel26 2.6.20-1 seemed to cause X to crash at startup. ATI Radeon driver/xf86-video-ati used. Downgrading things like xorg-server 1.2.0-1 didn't help, only downgrading to kernel26 2.6.19.2-1 (so everything except kernel26 is currently up-to-date testing). I hope that the info. I provide is of some use. Thanks.
Comment by Tobias Powalowski (tpowa) - Sunday, 11 February 2007, 10:03 GMT
could you try to downgrade just libx11 from current to libx11-1.1-2?
Comment by Erik C (Linteg) - Tuesday, 27 February 2007, 18:49 GMT
I can confirm this, however, if I disable exa it's a lot faster (with an X800XL & the opensource radeon driver).
Comment by Jan de Groot (JGC) - Tuesday, 27 February 2007, 22:11 GMT
As EXA is still not the prefered rendering method, I don't think this is a big issue. I haven't found any problems with a radeon X550SE, either with the fglrx driver or the opensource drivers.
Comment by Sergej Pupykin (sergej) - Tuesday, 06 March 2007, 18:06 GMT
I have the same issue with sis650 video... May be this is xorg upstream bug?..
Comment by Jacek Poplawski (Jacek Poplawski) - Thursday, 10 May 2007, 19:55 GMT
Now it's even worse, because new version of xf86-input-keyboard and xf86-input-mouse doesn't work with xorg-server-1.1.1, so I will need to skip 3 packages in my updates now :(

Loading...