Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63644 - [linux] gcc plugins need rebuild to fix dkms packages

Attached to Project: Arch Linux
Opened by Bastian Beischer (totsilence) - Tuesday, 03 September 2019, 20:41 GMT
Last edited by Antonio Rojas (arojas) - Saturday, 07 September 2019, 07:56 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When trying to build a DKMS package from the AUR I found the following problem:

cc1: error: incompatible gcc/plugin versions
cc1: error: fail to initialize plugin ./scripts/gcc-plugins/structleak_plugin.so

(this was with hid-lg-g710-plus-dkms-git in the AUR). I was able to fix this by rebuilding the "linux" and "linux-headers" packages. Was the structleak_plugin.so in linux 5.2.11.arch1-1 compiled with a GCC release other than 9.1.0? Or does this depend on some other package update? I'm using testing if that matters.

This task depends upon

Closed by  Antonio Rojas (arojas)
Saturday, 07 September 2019, 07:56 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Local issue
Comment by Bastian Beischer (totsilence) - Wednesday, 04 September 2019, 07:32 GMT
One can reproduce this problem as follows:

1) echo 'int main() { return 0; }' > test.c
2) gcc -fplugin=/usr/src/linux-5.2.11.arch1/scripts/gcc-plugins/structleak_plugin.so test.c

Loading...