Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63641 - [LDDM][GDM] Launching desktop needs user to have permission to homedir, missing error message

Attached to Project: Arch Linux
Opened by Sandro Volery (volery) - Tuesday, 03 September 2019, 14:31 GMT
Last edited by Doug Newgard (Scimmia) - Tuesday, 03 September 2019, 14:32 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

A user needs to have permissions to write to his own homedir to log in to a desktop via the most common desktop managers.
This becomes a problem if one decides to set up a new system but keep his home partition since the new user will have a different ID than the old one with the same name.
Having permissions to access the home directory makes sense for configurations, but the kernel log should output a error message which states just that, since we were trying for hours to make sense of the logfiles.

Additional info:
* package version(s)
* config and/or log files etc.
* link to upstream bug report, if any

Steps to reproduce:

1. Reinstall any arch linux but keep home partition
2. Create user with the same name and same home directory
3. Restart lddm or gdm (most likely any desktop manager), and try to log in
This task depends upon

Closed by  Doug Newgard (Scimmia)
Tuesday, 03 September 2019, 14:32 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Config issue

Loading...