Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63627 - [avahi] avahi-discover: DeprecationWarning: Importing dbus.glib

Attached to Project: Arch Linux
Opened by Juan Simón (j1simon) - Monday, 02 September 2019, 17:35 GMT
Last edited by Doug Newgard (Scimmia) - Monday, 02 September 2019, 17:39 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

$ avahi-discover
/usr/bin/avahi-discover:45: DeprecationWarning: Importing dbus.glib to use the GLib main loop with dbus-python is deprecated.
Instead, use this sequence:

from dbus.mainloop.glib import DBusGMainLoop

DBusGMainLoop(set_as_default=True)

import dbus.glib
....

I have reported this issue in github too: https://github.com/lathiat/avahi/issues/246
This task depends upon

Closed by  Doug Newgard (Scimmia)
Monday, 02 September 2019, 17:39 GMT
Reason for closing:  Not a bug

Loading...