Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63621 - [light] fails to adjust brightness after update to v1.2

Attached to Project: Community Packages
Opened by Ahmed (sahaf) - Sunday, 01 September 2019, 17:45 GMT
Last edited by Maxim Baz (maximbaz) - Sunday, 01 September 2019, 18:24 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Maxim Baz (maximbaz)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:

Latest update v1.2 fails to adjust the brightness without sudo due to permission related issue, based on the verbose output.

Additional info:
* light v1.2
* sysfs/backlight/intel_backlight


Steps to reproduce:
* Update to latest light v1.2
* execute: light -v 3 -U 10

Output:
helpers.c:21: Error: could not open '/home/ahm/.config/light/targets/sysfs/backlight/auto/minimum' for reading
helpers.c:21: Error: Verify it exists with the right permissions
helpers.c:45: Error: could not open '/sys/class/backlight/intel_backlight/brightness' for writing
helpers.c:45: Error: Verify it exists with the right permissions
impl/sysfs.c:133: Error: failed to write to sysfs device
light.c:905: Error: failed to write to target
main.c:20: Error: Execution failed

This task depends upon

Closed by  Maxim Baz (maximbaz)
Sunday, 01 September 2019, 18:24 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Thanks for reporting! This is due to recent change in  FS#63493 , we now use udev rules to avoid suid, and as per upstream docs you must add your user to the `video` group.

Loading...