Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63588 - grub-mkconfig contains bashism but uses /bin/sh shebang

Attached to Project: Arch Linux
Opened by Xuanrui Qi (xuanrui) - Thursday, 29 August 2019, 10:20 GMT
Last edited by Christian Hesse (eworm) - Thursday, 29 August 2019, 10:43 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Christian Hesse (eworm)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

grub-mkconfig contains the bashism `$EUID`, while in standard POSIX shell it should be `$(id -u)`. This breaks the script on systems where /bin/sh is not symlinked to bash, especially on systems where /bin/sh is dash, because `$EUID` does not work in dash.
This task depends upon

Closed by  Christian Hesse (eworm)
Thursday, 29 August 2019, 10:43 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Fallback is available.
Comment by Christian Hesse (eworm) - Thursday, 29 August 2019, 10:43 GMT
The script has a fallback to use `id -u` in case EUID is not set.
https://git.savannah.gnu.org/cgit/grub.git/tree/util/grub-mkconfig.in?h=grub-2.04#n105

Loading...