Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63568 - [apm] Change python2 to a build dependency

Attached to Project: Community Packages
Opened by mxks (mxks) - Tuesday, 27 August 2019, 06:26 GMT
Last edited by Balló György (City-busz) - Thursday, 29 August 2019, 19:31 GMT
Task Type Bug Report
Category Packages
Status Assigned
Assigned To Nicola Squartini (tensor5)
Architecture All
Severity Very Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 1
Private No

Details

Description:

Change python2 to a build dependency. python (2 or 3) is required when building the project but not during runtime.

Additional info:
* package version: apm 2.4.3-1
* https://github.com/atom/apm
* https://github.com/atom/apm/pull/690
* https://www.archlinux.org/packages/community/x86_64/apm/

Steps to reproduce:
1. Install apm from community: pacman -S apm
2. python2 will be installed as a dependency
This task depends upon

Comment by mxks (mxks) - Tuesday, 27 August 2019, 06:30 GMT
Can the python2 dep be changed to python3?
Comment by Nicola Squartini (tensor5) - Saturday, 09 November 2019, 07:02 GMT
apm now depends on python3. I'm still not sure if it's not required at runtime.

Loading...