Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63540 - [gst-plugins-base] doesn't build, cannot find gdk-pixbuf-2.0

Attached to Project: Arch Linux
Opened by Andreas Baumann (andreas_baumann) - Friday, 23 August 2019, 14:37 GMT
Last edited by Antonio Rojas (arojas) - Monday, 26 August 2019, 05:11 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

New meson support is broken:

Run-time dependency gdk-pixbuf-2.0 found: NO (tried pkgconfig)

meson.build:259:0: ERROR: Dependency "gdk-pixbuf-2.0" not found, tried pkgconfig

Additional info:
* package version(s)L 1.16.0-3

Steps to reproduce:
asp export gst-plugins-base
cd gst-plugins-base
staging-x86_64-build
This task depends upon

Closed by  Antonio Rojas (arojas)
Monday, 26 August 2019, 05:11 GMT
Reason for closing:  Not a bug
Comment by loqs (loqs) - Friday, 23 August 2019, 15:28 GMT
Run-time dependency gdk-pixbuf-2.0 found: YES 2.38.1
tested with staging-x86_64-build, testing-x86_64-build and extra-x86_64-build all produce the above and complete successfully.
Comment by Andreas Baumann (andreas_baumann) - Saturday, 24 August 2019, 10:40 GMT
Tried also with vanilla devtools on 64-bit, they work.
So, I start to think, this is a devtools issue (devtools32 version).
Comment by Andreas Baumann (andreas_baumann) - Saturday, 24 August 2019, 10:55 GMT
In my chroot there is no gdk-pixbuf2, gtk3, sdl,qt5 when I execute arch-meson.
Those are all checkdepends. Maybe something changed in the way chroots are created
like checkdepends was installed in the beginning and now before the check hook?
Comment by Andreas Baumann (andreas_baumann) - Saturday, 24 August 2019, 13:23 GMT
I don't get it: I have two machines and chroots working fine, one not. I changed caches, devtools, checked
out again. No difference. 2 Working one not. I'm clueless..
Comment by Andreas Baumann (andreas_baumann) - Saturday, 24 August 2019, 16:17 GMT
I have the feeling this correlates with  FS#62453 .

Loading...