Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63532 - [hplip] hplip complains there are no ppd files for printer despite them existing. Cannot print.

Attached to Project: Arch Linux
Opened by Lance (Raansu) - Thursday, 22 August 2019, 19:38 GMT
Task Type Bug Report
Category Packages: Extra
Status Unconfirmed
Assigned To No-one
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 3
Private No

Details

Description:
Trying to add my wireless printer, photosmart C4795, I run into an issue where it's complaining that there are no PPD files for it. But it does exist and it did work in a previous version. I don't remember exact which version that was because it was a while. But I know the PPD file exists. /usr/share/ppd/HP/hp-photosmart_c4700_series.ppd.gz which is what I remember it using last time.

'''[ransu@surface-go-paper ~]$ hp-setup

HP Linux Imaging and Printing System (ver. 3.19.6)
Printer/Fax Setup Utility ver. 9.0

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Found device: hp:/net/Photosmart_C4700_series?ip=192.168.1.8
error: No PPD found for model photosmart_c4700 using old algorithm.
error: No appropriate print PPD file found for model photosmart_c4700_series
'''

Additional info:
* package version(s): hplip 1:3.19.6-1

Steps to reproduce:
Install hplip and attempt to add a printer.
This task depends upon

Comment by Allan (4llan) - Wednesday, 28 August 2019, 01:14 GMT Comment by mozzi (Mozzi) - Thursday, 29 August 2019, 15:59 GMT
Same issue with HP Officejet Pro 7940.
Workaround : reinstalled image from a correct install via clonezilla dated July 31st

Here are the working versions from this date

cups : 2.2.11-2
cups-filters : 1.25.1-1
foomatic-db : 3:20190529-1
foomatic-db-gutenprint-ppds : 5.3.1-2
foomatic-db-nonfree : 3:20190529-1
foomatic-db-nonfree-ppds : 3:20190529-1
foomatic-db-ppds : 3:20190529-1
ghostscript : 9.27-1
gutenprint : 5.3.1-2
hplip : 1:3.19.6-1
libcups : 2.2.11-2
Comment by Biró Dávid (fxdave) - Wednesday, 11 September 2019, 19:44 GMT
Same issue with HP DeskJet Ink advantage 3000 series.

Loading...