Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63531 - [Discord] Launching Discord stuck on "Starting." Fixable by modifying .desktop file

Attached to Project: Community Packages
Opened by Luca Popesco (agsl) - Thursday, 22 August 2019, 19:02 GMT
Last edited by Filipe Laíns (FFY00) - Friday, 30 August 2019, 18:50 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Filipe Laíns (FFY00)
Architecture x86_64
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
The current Discord package will not launch on my system, and on several other systems, in its current state. The "Starting" window opens, but never goes away. It can be fixed by adding the following line to the .desktop file:

Path=/usr/bin


Steps to reproduce:

When launching Discord, the "starting" window is stuck open forever, and the main window never opens.
This task depends upon

Closed by  Filipe Laíns (FFY00)
Friday, 30 August 2019, 18:50 GMT
Reason for closing:  Fixed
Additional comments about closing:  discord 0.0.9-5
Comment by Matthew Sexton (wsdmatty) - Thursday, 29 August 2019, 05:28 GMT
I could not reproduce this on my system. You should provide more information about the multiple systems for which it occurred.

Discord launched from krunner, application menu, and desktop icon without problem on my system.
Comment by Luca Popesco (agsl) - Thursday, 29 August 2019, 21:45 GMT
Sure.

My first system where I'm experiencing the issue is my desktop - I've had this issue for several years, with the only common parts between installations being an X99 chipset (Asus X99-A board and 5820K CPU). I'm also experiencing it on a 2015 thinkpad X1 Carbon.

There is a similar report of an issue on this thread, with the same solution: https://bbs.archlinux.org/viewtopic.php?id=239096.

Worth noting, Discord launches just fine when installed via either Snap or Flatpak. It's only the native installation that requires this fix.

Comment by Filipe Laíns (FFY00) - Friday, 30 August 2019, 08:06 GMT
Can you run `which discord` please?
Comment by Luca Popesco (agsl) - Friday, 30 August 2019, 14:25 GMT
```
~ $ which discord
/usr/bin/discord
```
The desktop file is: /usr/share/applications/discord.desktop

If launched from the terminal, it has the same issue unless I'm in /usr/bin/
Comment by Filipe Laíns (FFY00) - Friday, 30 August 2019, 18:29 GMT
Oh, okay. I am not sure what's the source of the issue but it doesn't hurt to patch the .desktop file. I will release a new package revision.

Loading...