Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63508 - [archiso] building releng fails on the CK kernel

Attached to Project: Arch Linux
Opened by michael Lojkovic (zerophase) - Monday, 19 August 2019, 19:47 GMT
Last edited by Eli Schwartz (eschwartz) - Tuesday, 20 August 2019, 01:10 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
When running the CK kernel archiso fails to successfully build the releng profile. Baseline builds without issue on CK or Arch. releng successfully builds on the Arch kernel.

Additional info:
* 42-1
* Error message: mount: work/efiboot: mount failed: Operation not permitted.

Steps to reproduce:
1. Install the CK kernel
2. During the install step select the gcc native option, turn on P6_NOPs, and switch initramfs compression to LZ4. (this step might not matter at all)
3. Boot up the CK kernel, and proceed with the releng install steps without making any edits.
4. Build will fail when work/efiboot cannot be mounted.
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Tuesday, 20 August 2019, 01:10 GMT
Reason for closing:  Not a bug
Additional comments about closing:  The error is that your custom kernel is unable to run the "mount" command. Not an archiso issue.
Comment by loqs (loqs) - Tuesday, 20 August 2019, 00:34 GMT
Can you replicate the issue manually using the commands https://git.archlinux.org/archiso.git/tree/configs/releng/build.sh#n178 to lines 183?
Does dmesg have any additional information on the mount failure?
Initially this looks like an issue with the custom kernel rather than archiso.
Comment by michael Lojkovic (zerophase) - Tuesday, 20 August 2019, 00:45 GMT
dmesg does not have anything listed in it.

running:
sudo mount /home/user/isos/archlive/work/iso/EFI/archiso/efiboot.img /home/user/isos/archlive/work/efiboot

replicates the issue. What could the issue possibly be? The CK kernel is largely based off of the Arch kernel. I'll let graysky know about this.

Loading...