Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63491 - [imagescan] SANE backend not active with bugfix

Attached to Project: Community Packages
Opened by danieltetraquark (danieltetraquark) - Saturday, 17 August 2019, 14:01 GMT
Last edited by Antonio Rojas (arojas) - Sunday, 05 January 2020, 19:33 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Antonio Rojas (arojas)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

Description:
It seems that within the current PKGBUILD, there is a workaround for some bug (?) https://git.archlinux.org/svntogit/community.git/tree/trunk/PKGBUILD?h=packages/imagescan#n40 which causes SANE to stop working properly with imagescan scanners.

See also https://www.reddit.com/r/archlinux/comments/cly2m4/sane_imagescanv3_and_epson_et2750_ecotank/

If you remove the corresponding bug "fix" line, SANE works properly with imagescan scanners.


Additional info:
* package version 3.57.0


Steps to reproduce:

Have a imagescan scanner, run simple scan GUI -> no scanner found.
Build package without the bug "fix" -> scanner found and works in simple scan GUI.
This task depends upon

Closed by  Antonio Rojas (arojas)
Sunday, 05 January 2020, 19:33 GMT
Reason for closing:  Fixed
Additional comments about closing:  imagescan 3.61.0-2
Comment by Damián Barberón (damian01w) - Wednesday, 02 October 2019, 11:50 GMT
Same issue here. SANE backend is broken in current version of imagescan 3.59.2-1.

Rebuilding imagescan pkg without specific LDFLAGS line, works properly with SANE backend.
Comment by Evert Vorster (evorster) - Monday, 07 October 2019, 08:33 GMT
Same here, quite frustrating..
Comment by Patrick Smith (pat42smith) - Sunday, 13 October 2019, 00:56 GMT
I also see this. After building and installing 3.59.2-2 from the original PKGBUILD, scanimage -L does not find my scanner. After commenting out the 'sed ... libtool' line and rebuilding, scanimage -L does find my scanner.
Comment by Christophe Drevet-Droguet (dr4Ke) - Tuesday, 29 October 2019, 18:06 GMT
Hit it too.
Comment by Evert Vorster (evorster) - Friday, 15 November 2019, 10:29 GMT
With the new version this bug is still present. The package works fine without the "fix"
It is obvious that the "fix" removes the link to a needed library. Personally I don't care if imagescan links to libraries that it does not use, as long as it links to libraries that it DOES use.

Comment by danieltetraquark (danieltetraquark) - Tuesday, 26 November 2019, 14:16 GMT
Can confirm that in the latest version the bug is still present (tested on a fresh install)
Comment by Antonio Rojas (arojas) - Sunday, 15 December 2019, 10:52 GMT
Since I can't reproduce the issue, can someone test if replacing /usr/lib/utsushi/sane/libsane-utsushi.so.1.0.28 *only* with the one from a build without the libtool fix helps?
Comment by Damián Barberón (damian01w) - Sunday, 15 December 2019, 17:41 GMT
Yes, replacing /usr/lib/utsushi/sane/libsane-utsushi.so.1.0.28 with the one from a build without the libtool fix works for me.
Comment by Antonio Rojas (arojas) - Sunday, 15 December 2019, 18:01 GMT
OK thanks. Now please do the following (starting with the unmodified repo package). For each of these libraries:

libjpeg.so.8
libcnx-usb.so.0
libusb-1.0.so.0
libcnx-hexdump.so.0
libboost_filesystem.so.1.71.0
libboost_system.so.1.71.0
libboost_program_options.so.1.71.0
libltdl.so.7
libudev.so.1
libtiff.so.5
libm.so.6

run 'sudo patchelf --add-needed library-name /usr/lib/utsushi/sane/libsane-utsushi.so.1.0.28' (where library-name is the name of the library). After each step check if it works, and tell me which one fixes the issue.

Comment by Damián Barberón (damian01w) - Sunday, 15 December 2019, 23:18 GMT
Antonio, doing patchelf for libcnx-hexdump.so.0 fixes the issue.

Loading...