Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63435 - [mypy] package is missing a dependency

Attached to Project: Community Packages
Opened by Daniel Todorov (dt_) - Sunday, 11 August 2019, 19:11 GMT
Last edited by Chih-Hsuan Yen (yan12125) - Tuesday, 13 August 2019, 14:13 GMT
Task Type Bug Report
Category Packages
Status Assigned
Assigned To Maxime Gauduin (Alucryd)
Morten Linderud (Foxboron)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 5
Private No

Details

Description:

Upon being ran, encounters an unhandled exception and exits. The application seems to requite the package "python-typing_extensions" with version >= 3.7.4, while the most recent version in the repository is 3.7.2-2. Thus, as of right now, it's not possible to run the program without using pip/conda/venv.
I've attached the output of the application.

Version:
mypy 0.720-1

Config and/or log files etc.
Not applicable.

Link to upstream bug report, if any:
Not applicable.

Steps to reproduce:
1. Make sure python-typing_extensions's version is < 3.7.4. (As of right now, the most recent version in Community is 3.7.2-2, so that should be easy. If the package gets updated, the issue can be reproduced by uninstalling python-typing_extensions (which is not in the list of mypy's dependencies)).
2. Run /bin/mypy

Note:
I've marked the severity as high, but if "python-typing_extensions" gets updated, the severity of the issue will lessen.
This task depends upon

Comment by Tomas Krizek (tkrizek) - Monday, 12 August 2019, 14:26 GMT
python-typing_extensions should also be explicitly listed in depends field of mypy's PKGBUILD.

It seems to have been added by upstream as a pip dependency:

$ pip3 show mypy | grep Requires
Requires: typed-ast, typing-extensions, mypy-extensions
Comment by Maxime Gauduin (Alucryd) - Saturday, 17 August 2019, 14:35 GMT
typing_extensions are now up to date in community.
Comment by Chih-Hsuan Yen (yan12125) - Sunday, 18 August 2019, 12:39 GMT
> typing_extensions are now up to date in community.

Thanks! But now there is another issue: community/python-typing_extensions 3.7.4 is recognized as 3.7.2 by setuptools:

$ pip show typing_extensions | grep Version
Version: 3.7.2

As a result, mypy still fails with:

pkg_resources.ContextualVersionConflict: (typing-extensions 3.7.2 (/usr/lib/python3.7/site-packages), Requirement.parse('typing_extensions>=3.7.4'), {'mypy'})

In the upstream repository, the commit that bumps the typing_extensions package [1] is one commit newer than the commit that bumps the typing package [2].

[1] https://github.com/python/typing/commit/27f2e427b9b677401961b5da1762f8380a929bb8
[2] https://github.com/python/typing/commit/baf63c5924a2b9695175df5d47ced40596024b78
Comment by Maxime Gauduin (Alucryd) - Tuesday, 20 August 2019, 16:21 GMT
Argh, and they didn't bother fixing the tag. Just pushed an updated package, thanks for the heads up!
Comment by Yauhen (actionless) - Saturday, 21 September 2019, 02:51 GMT
what's the status of this? it passed about a month from the last comment but i see typing_extensions still didn't updated

Loading...