Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#63404 - error: unable to lock database

Attached to Project: Pacman
Opened by grenudi (grenudi) - Wednesday, 07 August 2019, 23:33 GMT
Last edited by Allan McRae (Allan) - Thursday, 08 August 2019, 02:11 GMT
Task Type Bug Report
Category General
Status Closed
Assigned To No-one
Architecture x86_64
Severity Low
Priority Normal
Reported Version 5.1.3
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Summary and Info:
error: unable to lock database

Steps to Reproduce:
-try to install any package using: pacman -S packagename
-press Ctrl+C in the middle of the installation process
-done. you broke it!

Now next time I run any command from pacman I get
error: failed to update core (unable to lock database)
...extra...
...community...

Works everytime. Quite a popular problem actually.
removing /var/lib/pacman/db.lck seems to help.
This task depends upon

Closed by  Allan McRae (Allan)
Thursday, 08 August 2019, 02:11 GMT
Reason for closing:  Not a bug
Comment by grenudi (grenudi) - Wednesday, 07 August 2019, 23:36 GMT
unable to lock database

Ok, seems like you right about quit signal. I believe that it is installers like makepkg and GUI pamac that send QUIT signal on CTRL+C or when you press cancel in pamac.

P.S. ctrl+/ doesn't interrupt pacman for me (gif included)
Comment by Eli Schwartz (eschwartz) - Wednesday, 07 August 2019, 23:42 GMT
This should not happen just for CTRL+C while downloading packages, which I know because I do the CTRL+C all the time myself. Are you sure you don't have another background pacman process at the time?
Comment by Eli Schwartz (eschwartz) - Thursday, 08 August 2019, 01:11 GMT
Uh, someone pointed out that you didn't even use CTRL+C, you used CTRL+\

That's the control sequence for manually forcing a coredump (or to be exact, SIGQUIT). I don't know why you feel surprised that a coredump leaves the lockfile in place -- the whole point of dumping a core is that we want to emulate a completely abnormal fatal crash, which... surprise, leaves a lockfile as a sign that "something very bad happened".

Loading...