Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63384 - [vapoursynth] vspipe with R47-1 fails with "Failed to initialize VapourSynth environment"

Attached to Project: Community Packages
Opened by Jacob S (Gourdcaptain) - Monday, 05 August 2019, 23:48 GMT
Last edited by Maxime Gauduin (Alucryd) - Sunday, 01 September 2019, 07:33 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Maxime Gauduin (Alucryd)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
Running a very basic vapoursynth script (no external dependencies beyond basic Vapoursynth, just loads a file and directly outputs) with no other vapoursynth packages fails with "Failed to initialize VapourSynth environment". R46-1 works. (This also occurs with all my standard vapoursynth plugins I use installed, but I uninstalled all of them to make sure it wasn't related to them.)

Additional info:
* vapoursynth-R47-1

Script to produce error (save as test.vpy):
-----
import vapoursynth as vs
core = vs.get_core()
filename = globals()["file"]

clip = core.ffms2.Source(filename)
clip.set_output()
------
Command (need input file, here using "test.mkv"): vspipe -p -y -a file=test.mkv test.vpy - | mpv -

This task depends upon

Closed by  Maxime Gauduin (Alucryd)
Sunday, 01 September 2019, 07:33 GMT
Reason for closing:  Fixed
Additional comments about closing:  R47.2
Comment by Jacob S (Gourdcaptain) - Friday, 09 August 2019, 21:20 GMT
Fixed in R47.1-1.

Loading...