Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63360 - [deluge] Missing python-cairo dependency

Attached to Project: Arch Linux
Opened by Casper Bezemer (casperb) - Sunday, 04 August 2019, 14:50 GMT
Last edited by Doug Newgard (Scimmia) - Sunday, 04 August 2019, 15:22 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
After a clean install, running `deluge` crashes the program reporting:

File "/usr/lib/python3.7/site-packages/deluge/ui/gtk3/piecesbar.py", line 20, in <module>
import cairo # Backward compat cairo <= 1.15
ModuleNotFoundError: No module named 'cairo'

The `python-cairo` package is required, but it is only listed as a "(Make)" dependency.

Install the `python-cairo` package to get `deluge` to run.

Additional info:
* package version(s): deluge 2.0.3-1 - Last updated 2019-06-18

Steps to reproduce:
- Remove packages `python-cairo` and `deluge` (# pacman -R python-cairo deluge)
- Perform the install of the `deluge` package (# pacman -Sy deluge)
- Run `deluge` ($ deluge)
- Deluge crashes with "ModuleNotFoundError: No module named 'cairo'"-message
This task depends upon

Closed by  Doug Newgard (Scimmia)
Sunday, 04 August 2019, 15:22 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Pay more attention to what pacman tells you. Covered by optdeps

Loading...