Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63357 - [vim] is of "poor packaging"

Attached to Project: Arch Linux
Opened by lilydjwg (lilydjwg) - Sunday, 04 August 2019, 10:12 GMT
Last edited by Levente Polyak (anthraxx) - Sunday, 04 August 2019, 21:28 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Levente Polyak (anthraxx)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

According to  FS#63356 , current vim PKGBUILD is of "poor packaging" because "two ./configure and make sections means this should be two PKGBUILDs".

Additional info:
* vim / gvim / vim-runtime 8.1.1776
* https://bugs.archlinux.org/task/63356

Steps to reproduce:
* file an issue to pacman about this PKGBUILD not able to generate correct debug packages
* get your issue closed as "Not a bug" because of "Poor packaging"

Please improve this PKGBUILD.
This task depends upon

Closed by  Levente Polyak (anthraxx)
Sunday, 04 August 2019, 21:28 GMT
Reason for closing:  None
Additional comments about closing:  focusing on technical change request in title and details would bring you further compared to a purely insulting way to request something without any useful technical change and reasoning by just throwing poo around and adding a link to another ticket.
Comment by Eli Schwartz (eschwartz) - Sunday, 04 August 2019, 19:00 GMT
The logical solution would be to install gvim, which is what the gvim package is, and symlink vim to it, rather than the other way around. In which case the binaries would not conflict. (The packages still do, because of the symlink.) This would arguably make sense to do regardless of what makepkg does or does not do.

Loading...