Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63329 - [grub-theme-vimix] Change to '/usr/share' breaks theme

Attached to Project: Community Packages
Opened by Christoper Daley (luciferin) - Wednesday, 31 July 2019, 15:04 GMT
Last edited by Santiago Torres (sangy) - Wednesday, 31 July 2019, 16:41 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

The latest version has changed the install directory from '/boot/grub' to '/usr/share'. My GRUB configuration (EFS) is not able to load the theme from this location, and would require me to manually copy the files to the boot partition.


Additional info:
* package version(s)
20190605-1
* config and/or log files etc.
GRUB_THEME="/usr/share/grub/themes/Vimix/theme.txt"


Steps to reproduce:

Edit /etc/default/grub to point to '/usr/share/grub/themes/Vimix/theme.txt'

Run 'grub-mkconfig -o /boot/grub/grub.cfg'
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-linux
Found initrd image: /boot/intel-ucode.img /boot/initramfs-linux.img
Found fallback initrd image(s) in /boot: initramfs-linux-fallback.img
Found Windows Boot Manager on /dev/sdb2@/efi/Microsoft/Boot/bootmgfw.efi
done

Steps to reproduce:
This task depends upon

Closed by  Santiago Torres (sangy)
Wednesday, 31 July 2019, 16:41 GMT
Reason for closing:  Not a bug
Additional comments about closing:  see comment
Comment by nl6720 (nl6720) - Wednesday, 31 July 2019, 16:27 GMT
Packages should not put stuff in /boot/grub/ .
If you want to use the theme either copy it manually to /boot/grub/themes/ or run grub-install with the option "--themes=ThemeName".
And don't use /usr/share/grub/themes/* in /etc/default/grub, the stuff in /boot/grub/ should be fully self-contained.

Loading...