Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#63328 - [bluez] Sinks not always connected, especially with Sony headsets

Attached to Project: Arch Linux
Opened by Peter Klotz (p.klotz) - Wednesday, 31 July 2019, 07:21 GMT
Last edited by freswa (frederik) - Saturday, 22 February 2020, 20:57 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Here is a bug ( initially reported for PulseAudio stating that sinks for headsets are not always connected. Especially Sony headsets are mentioned throughout the bug. It turns out the reason is that the a2dp profile is not properly advertised during connect. Lots of people have tried different workarounds with varying degrees of success.

According to the Bug Report finally a fix was applied to bluez to connect available sinks even if not advertised ( The fix will be part of bluez>5.50. However the last release of bluez was on 3rd June 2018 (, so it could still take a while before users have access to it.

It tried the fix together with a Sony WH-1000XM3 headset and it worked exactly as expected. The a2dp sink appears on connect and PulseAudio immediately switches the streams to the headphones.

So I suggest applying the fix to the Arch Linux bluez 5.50 package. It is really frustrating if new headphones that are simply expected to be plug-and-play require rather technical workarounds which most users are not capable of.

Regards, Peter.
This task depends upon

Closed by  freswa (frederik)
Saturday, 22 February 2020, 20:57 GMT
Reason for closing:  Fixed
Additional comments about closing:  5.50 is out for some time now. Please re-open if it's not fixed though. Thanks :)
Comment by Peter Klotz (p.klotz) - Wednesday, 31 July 2019, 07:34 GMT
The attached (trivial) patch is needed to make bluez compile since gcc 9 is used in Arch Linux.

This is also mentioned in [ FS#63324 ][1].