Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63300 - [lilypond] Blank PDF emitted when LilyPond file contains \header

Attached to Project: Community Packages
Opened by Chris Wong (lfairy) - Sunday, 28 July 2019, 10:08 GMT
Last edited by Balló György (City-busz) - Sunday, 01 September 2019, 10:12 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Evgeniy Alexeev (arcan1s)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

When I compile a simple test case (foo.ly) using the official 2.19.82 build [1], it emits a PDF with the score as expected (foo-upstreambuild.pdf).

But when I compile the same input with the Arch Linux build, it shows the following warning and emits a blank PDF (foo-archbuild.pdf):

> warning: compressing over-full page by 50968.1 staff-spaces
> warning: page 1 has been compressed

Steps to reproduce:

1. Download the attached foo.ly
2. lilypond foo.ly

Package versions:

lilypond 2.19.82-1
guile1.8 1.8.8-7
python2 2.7.16-1
texlive-core 2019.50917-1
ghostscript 9.27-1
pango 1:1.44-1
fontconfig 2:2.13.1+12+g5f5ec56-1

[1] http://lilypond.org/download/binaries/linux-64/lilypond-2.19.82-1.linux-64.sh
This task depends upon

Closed by  Balló György (City-busz)
Sunday, 01 September 2019, 10:12 GMT
Reason for closing:  Fixed
Additional comments about closing:  pango 1:1.44.5-1
Comment by Thomas Sefzick (thse) - Sunday, 28 July 2019, 18:06 GMT
lilypond has a problem with pango 1:1.44.

Precompiled lilypond 2.19.82-1 does wrong space calculations => empty 1st page, no lyrics

Reinstalling pango 1:1.43 "solves" the problem.
Comment by Thomas Sefzick (thse) - Sunday, 28 July 2019, 18:38 GMT
The official 2.19.82 build works because it contains its own libraries, especially libpango-1.0.so.0.4000.1 - which would be equivalent to arch-package pango-1:1.40
Comment by stefan (cockroach) - Sunday, 28 July 2019, 22:32 GMT
Could this be related to https://bugs.archlinux.org/task/63297 ?
Comment by Caleb Maclennan (caleb) - Monday, 29 July 2019, 09:30 GMT
It took me a long time hacking on my system trying to figure out why my entire music library started generating blank PDFs before I found this bug report. The high severity is appropriate here, the Arch Linux default Lilypond package is practically useless now and from an end user perspective there is very little clue as to why.
Comment by Caleb Maclennan (caleb) - Monday, 29 July 2019, 09:32 GMT Comment by Caleb Maclennan (caleb) - Monday, 29 July 2019, 09:38 GMT
Note this is not just about `\header` in Lilypond. Although that happens to be one way to trigger this, it can be triggered with all sorts of different things. Almost any text anywhere except the first line of the footer will to it (including having Chords notation in a staff). Even the `\alternative` syntax in a staff will trigger this (possibly because of the font used in the 1./2. labels).
Comment by Thomas Sefzick (thse) - Tuesday, 30 July 2019, 20:25 GMT
The only thing we can do at the moment is to downgrade to "pango 1:1.43", add "pango" to "IgnorePkg" in /etc/pacman.conf and wait for the lilypond developers to change their code. Actually the git version of lilypond combined with pango 1.44 refuses to compile.
Comment by Caleb Maclennan (caleb) - Tuesday, 06 August 2019, 07:00 GMT Comment by Caleb Maclennan (caleb) - Tuesday, 06 August 2019, 09:29 GMT
Comment by A. Bosch (progandy) - Wednesday, 14 August 2019, 22:03 GMT
This should be fixed since pango 1.44.4 with merge request #134[1]. See the pango bug report above for more details.

https://gitlab.gnome.org/GNOME/pango/merge_requests/134
Comment by Caleb Maclennan (caleb) - Friday, 23 August 2019, 10:33 GMT
I can confirm this is fixed with the latest (1.44.5) Pango packages being shipped in [community]. Nothing on the Lilypond side has to change, the fault was basically entirely in Pango. They got a little ahead of themselves.

This bug report can be closed.

Loading...