Community Packages

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#63277 - [lxc] Containers not starting with 1:3.2.1-1

Attached to Project: Community Packages
Opened by Sibren Vasse (SibrenVasse) - Thursday, 25 July 2019, 12:44 GMT
Last edited by Doug Newgard (Scimmia) - Thursday, 26 March 2020, 14:32 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sergej Pupykin (sergej)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 10
Private No


After upgrading to lxc 1:3.2.1-1 containers no longer start. Issue no longer present after downgrading to 1:3.1.0-2.

Additional info:
* lxc 1:3.2.1-1
* config and/or log files etc.
lxc-start container 20190725124013.432 ERROR cgfsng - cgroups/cgfsng.c:__do_cgroup_enter:1500 - No space left on device - Failed to enter cgroup "/sys/fs/cgroup/cpuset//lxc.monitor/container/cgroup.procs"
lxc-start container 20190725124013.433 ERROR start - start.c:__lxc_start:2009 - Failed to enter monitor cgroup
lxc-start container 20190725124013.433 ERROR lxccontainer - lxccontainer.c:wait_on_daemonized_start:872 - Received container state "STOPPING" instead of "RUNNING"
lxc-start container 20190725124013.434 ERROR lxc_start - tools/lxc_start.c:main:329 - The container failed to start
lxc-start container 20190725124013.434 ERROR lxc_start - tools/lxc_start.c:main:332 - To get more details, run the container in foreground mode
lxc-start container 20190725124013.434 ERROR lxc_start - tools/lxc_start.c:main:334 - Additional information can be obtained by setting the --logfile and --logpriority options
* link to upstream bug report, if any
This task depends upon

Closed by  Doug Newgard (Scimmia)
Thursday, 26 March 2020, 14:32 GMT
Reason for closing:  Fixed
Additional comments about closing:  lxc 1:3.2.1-2
Comment by DaveD (daved) - Thursday, 25 July 2019, 21:56 GMT
same same issue
Comment by John (graysky) - Saturday, 27 July 2019, 11:21 GMT Comment by Sibren Vasse (SibrenVasse) - Saturday, 27 July 2019, 12:02 GMT
I can reproduce the issue on these kernels:
core/linux 5.2.3.arch1-1
core/linux-lts 4.19.61-1
aur/linux-mainline 5.3rc1-1

The workaround in a post from your link 'solves' the issue. (
Comment by John (graysky) - Saturday, 27 July 2019, 19:12 GMT
I am seeing it on linux-lts but not on linux. Odd.
@Sibren - Recommend you open an issue providing upstream guys with the config and logs they want. Link =
I have found them to be very responsive and your logs, etc. could help them to pin point the bug.
Comment by John (graysky) - Saturday, 27 July 2019, 22:31 GMT
@Sibren - See

If you create the dropin as I suggest, does it work for you? I am on the latest lxc with the dropin and have no issues.
Comment by Sibren Vasse (SibrenVasse) - Sunday, 28 July 2019, 04:11 GMT
I'm starting my containers using lxc-start -n <container>, so I don't think editing systemd service files will change anything?
Comment by John (graysky) - Sunday, 28 July 2019, 09:09 GMT
I replied in your upstream bug report:
Comment by Sibren Vasse (SibrenVasse) - Monday, 29 July 2019, 13:02 GMT Comment by Fran├žois D. (sangfroid) - Wednesday, 31 July 2019, 13:07 GMT
Same issue for me since I've updated on lxc 1:3.2.1-1
Comment by Janhouse (janhouse) - Monday, 05 August 2019, 09:34 GMT
Same problem for me, downgrading to 3.1 helped.
Comment by Jackson Alley (jalley) - Wednesday, 07 August 2019, 13:37 GMT
Downgrading to 3.1 did not fix the issue for me.
Comment by Sibren Vasse (SibrenVasse) - Wednesday, 07 August 2019, 14:16 GMT
jalley, have you tried rebooting after downgrading?
Comment by Jackson Alley (jalley) - Wednesday, 07 August 2019, 15:31 GMT
Thanks, did take reboot, service restart insufficient
Comment by Fran├žois D. (sangfroid) - Saturday, 10 August 2019, 12:44 GMT
Downgrading to 3.1 fixed the issue after reboot.
Comment by Jackson Alley (jalley) - Thursday, 15 August 2019, 21:13 GMT
I think the ability to create tun devices as described in the wiki is broken even when downgraded. Can anyone else confirm?
Comment by John (graysky) - Thursday, 15 August 2019, 22:40 GMT
This FS is drifting off topic... I see it hasn't been assigned to anyone yet. When it is assigned, please apply upstream's fix as they do not seem to be planning a version bump for a while. Patch to apply:
Comment by Sergej Pupykin (sergej) - Wednesday, 09 October 2019, 13:43 GMT
Try lxc-1:3.2.1-2
Comment by Sibren Vasse (SibrenVasse) - Wednesday, 09 October 2019, 13:59 GMT
Issue no longer present for me using lxc-1:3.2.1-2.
Comment by Cedric Bellegarde (gnumdk) - Wednesday, 09 October 2019, 15:35 GMT
Removed my comment, worked after a second reboot.
Comment by John (graysky) - Wednesday, 09 October 2019, 18:43 GMT
@sergej - Works for me.
Comment by John (graysky) - Thursday, 26 March 2020, 06:13 GMT