Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63261 - Display refusing to work after Linux 5.2.x kernel update

Attached to Project: Arch Linux
Opened by N/A (Tlopfest) - Tuesday, 23 July 2019, 15:20 GMT
Last edited by freswa (frederik) - Saturday, 22 February 2020, 21:17 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To No-one
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Essentially, after having updated Arch to version 5.2.x, I cannot use the screen on my laptop anymore. It does a normal bootup, but then refuses to show anything after everything loads.
Most things work after downgrading to 5.1.9 however.
My setup of Arch does not initially go to an x-server, or even connect to wifi. It boots directly to terminal and I go from there.

Additional info:
* archlinux 5.2.x, linux-headers 5.2.x
* Will be happy to provide logs if told how to get either journal or latest log from the system via mounting or LiveUSB as a file or copyable text
* Laptop is Alienware 15 R3, Nvidia card installed, using bumblebee (started after getting to x-server) to access GPU.

Steps to reproduce:
Boot Arch after 5.2.x straight to terminal.
This task depends upon

Closed by  freswa (frederik)
Saturday, 22 February 2020, 21:17 GMT
Reason for closing:  None
Additional comments about closing:  This seems pretty stalled to me. If it's still an issue, please fill a re-open request. Thank you :)
Comment by loqs (loqs) - Tuesday, 23 July 2019, 15:50 GMT
 FS#63159  ?
Comment by Kochi (pelopor) - Wednesday, 24 July 2019, 14:07 GMT
Just stay with kernel 5.1.x for the moment. It looks like an upstream bug.
Comment by Eetu Närhi (rargh) - Wednesday, 07 August 2019, 20:06 GMT
Similar issues here with a HP Z Book 15 g3, Intel integrated graphics, from 5.2.x on. Screen freezes for a few seconds and runs for a few seconds sporadically. External display works normally. Logs don't show anything abnormal.
Comment by loqs (loqs) - Wednesday, 07 August 2019, 21:59 GMT
@pelopor and @rargh you both tried the workaround or patch from  FS#63159  and found this was a separate issue?
Comment by N/A (Tlopfest) - Wednesday, 07 August 2019, 22:17 GMT
I did not notice that bug report earlier, but the workaround works @loqs. Sorry for wasting everyone's time with this.
Comment by Eetu Närhi (rargh) - Thursday, 08 August 2019, 14:25 GMT
Missed that report too since my problem seemed slightly different, but yes the 'i915.enable_psr=0' workaround works for me too. Sorry about that!
Comment by Valera (khvalera) - Tuesday, 13 August 2019, 08:13 GMT
I confirm the problem !!! After updating, at the entrance to xfce4 the screen goes blank and the devices fall off. When you turn off visual effects in xfce4, everything works. I had to install linux-lts. The problem is observed on AMD Ryzen 3.

Loading...