Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63235 - [grub] 2.04 missing support for zstd on btrfs

Attached to Project: Arch Linux
Opened by raneon (raneon) - Saturday, 20 July 2019, 09:36 GMT
Last edited by Eli Schwartz (eschwartz) - Tuesday, 30 July 2019, 01:10 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Grub 2.04 is supposed to add zstd compression support for btrfs, but grub doesn't boot if /boot is compressed with zstd too.


Additional info:
grub 2.04

Steps to reproduce:
1. Compress / with zstd on a btrfs partition (including boot)
2. Restart
3. Grub shows the error: compression type 0x3 not supported

I tried to add btrfs in GRUB_PRELOAD_MODULES in /etc/default/grub and then I did run grub-mkconfig -o /boot/grub/grub.cfg, but it didn't help.
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Tuesday, 30 July 2019, 01:10 GMT
Reason for closing:  Not a bug
Additional comments about closing:  OP request: user error
Comment by Alexander Schnaidt (Namarrgon) - Saturday, 20 July 2019, 12:57 GMT
I can't reproduce. grub 2:2.04-1 boots fine from a freshly created btrfs mounted with -o compress-force=zstd before running pacstrap.

edit:
Are you sure that you reinstalled the grub payload into the mbr/esp after grub was updated to 2.04?
Comment by raneon (raneon) - Monday, 29 July 2019, 18:35 GMT
Oh, that is the step I was missing. Thanks, now it works! I really didn't know that I need to reinstall grub. Please close this bug.

Loading...