Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63215 - [gnome-control-center] segmentation fault when opening devices tab

Attached to Project: Arch Linux
Opened by Cameron Wood (cewood) - Wednesday, 17 July 2019, 13:22 GMT
Last edited by freswa (frederik) - Saturday, 22 February 2020, 21:25 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description: In gnome-control-center when attempting to open the devices tab, the application segmentation faults


Additional info:
* Version : gnome-control-center:3.32.2-1


Steps to reproduce:
* Open gnome-control-center
* Navigate to the "Devices" tab
* Application immediately crashes
* At this point gnome-control-center if restarted will crash again, because it remembers the last open tab. So you need to clear this by running `gsettings set org.gnome.ControlCenter last-panel ''`


Extra info:
* Output at time of crash:

$ gnome-control-center -v
14:49:47.0582 cc-object-storage: DEBUG: Finished creating D-Bus proxy for CcObjectStorage::dbus-proxy(org.gnome.SettingsDaemon.Color,/org/gnome/SettingsDaemon/Color,org.freedesktop.DBus.Properties)
14:49:47.0582 cc-object-storage: DEBUG: Adding object GDBusProxy (CcObjectStorage::dbus-proxy(org.gnome.SettingsDaemon.Color,/org/gnome/SettingsDaemon/Color,org.freedesktop.DBus.Properties) → 0x7fce10001d50) to the storage
14:49:47.0582 cc-object-storage: DEBUG: Finished creating D-Bus proxy for CcObjectStorage::dbus-proxy(org.gnome.SettingsDaemon.Color,/org/gnome/SettingsDaemon/Color,org.gnome.SettingsDaemon.Color)
14:49:47.0582 cc-object-storage: DEBUG: Adding object GDBusProxy (CcObjectStorage::dbus-proxy(org.gnome.SettingsDaemon.Color,/org/gnome/SettingsDaemon/Color,org.gnome.SettingsDaemon.Color) → 0x55e5dc839640) to the storage
14:49:47.0582 display-cc-panel: DEBUG: setting adjustment -1.000 to -1:-0
14:49:47.0583 display-cc-panel: DEBUG: setting adjustment -1.000 to -1:-0
14:49:47.0583 cc-object-storage: DEBUG: Finished creating D-Bus proxy for CcObjectStorage::dbus-proxy(org.gnome.Shell,/org/gnome/Shell,org.gnome.Shell)
14:49:47.0583 cc-object-storage: DEBUG: Adding object GDBusProxy (CcObjectStorage::dbus-proxy(org.gnome.Shell,/org/gnome/Shell,org.gnome.Shell) → 0x7fce10001de0) to the storage
14:49:47.0584 display-cc-panel: DEBUG: SensorProxy vanished
14:49:47.0584 display-cc-panel: DEBUG: Has no accelerometer
14:49:47.0585 display-cc-panel: DEBUG: Resetting current config!
14:49:47.0585 GLib-GObject: CRITICAL: g_object_ref: assertion 'G_IS_OBJECT (object)' failed
[1] 24513 segmentation fault (core dumped) gnome-control-center -v


* Output of coredump info:

$ coredumpctl info 24513
PID: 24513 (gnome-control-c)
UID: 1000 (cewood)
GID: 1000 (cewood)
Signal: 11 (SEGV)
Timestamp: Wed 2019-07-17 14:49:47 CEST (3min 45s ago)
Command Line: gnome-control-center -v
Executable: /usr/bin/gnome-control-center
Control Group: /user.slice/user-1000.slice/session-2.scope
Unit: session-2.scope
Slice: user-1000.slice
Session: 2
Owner UID: 1000 (cewood)
Boot ID: 0f26159b58c44acd86bc86fa78075827
Machine ID: 0c0b910c4fde4f5daad7b412dcf28d3d
Hostname: schrodinger
Storage: /var/lib/systemd/coredump/core.gnome-control-c.1000.0f26159b58c44acd86bc86fa78075827.24513.1563367787000000.lz4
Message: Process 24513 (gnome-control-c) of user 1000 dumped core.

Stack trace of thread 24513:
#0 0x000055e5da8d3d40 cc_display_config_equal (gnome-control-center)
#1 0x000055e5da8dbdb9 n/a (gnome-control-center)
#2 0x000055e5da8dc9c1 n/a (gnome-control-center)
#3 0x00007fce4007acaa g_closure_invoke (libgobject-2.0.so.0)
#4 0x00007fce40068706 n/a (libgobject-2.0.so.0)
#5 0x00007fce4006c89a g_signal_emit_valist (libgobject-2.0.so.0)
#6 0x00007fce4006d700 g_signal_emit (libgobject-2.0.so.0)
#7 0x000055e5da8d3cbc n/a (gnome-control-center)
#8 0x00007fce4015e4c4 n/a (libgio-2.0.so.0)
#9 0x00007fce401639c7 n/a (libgio-2.0.so.0)
#10 0x00007fce401147e5 n/a (libgio-2.0.so.0)
#11 0x00007fce4015e4c4 n/a (libgio-2.0.so.0)
#12 0x00007fce4015e4f9 n/a (libgio-2.0.so.0)
#13 0x00007fce3ff8fbb0 g_main_context_dispatch (libglib-2.0.so.0)
#14 0x00007fce3ff91b11 n/a (libglib-2.0.so.0)
#15 0x00007fce3ff91b51 g_main_context_iteration (libglib-2.0.so.0)
#16 0x00007fce4014150e g_application_run (libgio-2.0.so.0)
#17 0x000055e5da7fe3ab main (gnome-control-center)
#18 0x00007fce40274ee3 __libc_start_main (libc.so.6)
#19 0x000055e5da7fe3fe _start (gnome-control-center)

Stack trace of thread 24515:
#0 0x00007fce4033f667 __poll (libc.so.6)
#1 0x00007fce3ff91a80 n/a (libglib-2.0.so.0)
#2 0x00007fce3ff92a63 g_main_loop_run (libglib-2.0.so.0)
#3 0x00007fce400fe9c8 n/a (libgio-2.0.so.0)
#4 0x00007fce3ff6ea31 n/a (libglib-2.0.so.0)
#5 0x00007fce4041a57f start_thread (libpthread.so.0)
#6 0x00007fce4034a0e3 __clone (libc.so.6)

Stack trace of thread 24523:
#0 0x00007fce4033f667 __poll (libc.so.6)
#1 0x00007fce3ff91a80 n/a (libglib-2.0.so.0)
#2 0x00007fce3ff91b51 g_main_context_iteration (libglib-2.0.so.0)
#3 0x00007fce3000fbde n/a (libdconfsettings.so)
#4 0x00007fce3ff6ea31 n/a (libglib-2.0.so.0)
#5 0x00007fce4041a57f start_thread (libpthread.so.0)
#6 0x00007fce4034a0e3 __clone (libc.so.6)

Stack trace of thread 24514:
#0 0x00007fce4033f667 __poll (libc.so.6)
#1 0x00007fce3ff91a80 n/a (libglib-2.0.so.0)
#2 0x00007fce3ff91b51 g_main_context_iteration (libglib-2.0.so.0)
#3 0x00007fce3ff91ba2 n/a (libglib-2.0.so.0)
#4 0x00007fce3ff6ea31 n/a (libglib-2.0.so.0)
#5 0x00007fce4041a57f start_thread (libpthread.so.0)
#6 0x00007fce4034a0e3 __clone (libc.so.6)

Stack trace of thread 24524:
#0 0x00007fce40344e3d syscall (libc.so.6)
#1 0x00007fce3ff4311b g_cond_wait_until (libglib-2.0.so.0)
#2 0x00007fce3ffc0203 n/a (libglib-2.0.so.0)
#3 0x00007fce3ff67e4b n/a (libglib-2.0.so.0)
#4 0x00007fce3ff6ea31 n/a (libglib-2.0.so.0)
#5 0x00007fce4041a57f start_thread (libpthread.so.0)
#6 0x00007fce4034a0e3 __clone (libc.so.6)

Stack trace of thread 24525:
#0 0x00007fce40344e3d syscall (libc.so.6)
#1 0x00007fce3ff4311b g_cond_wait_until (libglib-2.0.so.0)
#2 0x00007fce3ffc0203 n/a (libglib-2.0.so.0)
#3 0x00007fce3ff67e4b n/a (libglib-2.0.so.0)
#4 0x00007fce3ff6ea31 n/a (libglib-2.0.so.0)
#5 0x00007fce4041a57f start_thread (libpthread.so.0)
#6 0x00007fce4034a0e3 __clone (libc.so.6)

Stack trace of thread 24522:
#0 0x00007fce40420415 pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0)
#1 0x00007fce2b37bebc n/a (i965_dri.so)
#2 0x00007fce2b37bab8 n/a (i965_dri.so)
#3 0x00007fce4041a57f start_thread (libpthread.so.0)
#4 0x00007fce4034a0e3 __clone (libc.so.6)

Stack trace of thread 24526:
#0 0x00007fce40344e3d syscall (libc.so.6)
#1 0x00007fce3ff4311b g_cond_wait_until (libglib-2.0.so.0)
#2 0x00007fce3ffc0203 n/a (libglib-2.0.so.0)
#3 0x00007fce3ff67e4b n/a (libglib-2.0.so.0)
#4 0x00007fce3ff6ea31 n/a (libglib-2.0.so.0)
#5 0x00007fce4041a57f start_thread (libpthread.so.0)
#6 0x00007fce4034a0e3 __clone (libc.so.6)
This task depends upon

Closed by  freswa (frederik)
Saturday, 22 February 2020, 21:25 GMT
Reason for closing:  Duplicate
Additional comments about closing:  FS#64321
Comment by Alexis Maiquez (Almamu) - Wednesday, 04 September 2019, 08:33 GMT
An easy way to reproduce the issue is:
Install the gnome and gnome-extra groups, install i3-gnome and NetworkManager from the aur and run the desired display manager (gdm should come as a default). Select i3 + GNOME as the xsession in GDM, login and then try to open the devices tab in gnome-control-center, the app should instantly crash as described by the reporter.
Comment by mattia (nTia89) - Tuesday, 05 November 2019, 20:51 GMT
I cannot reproduce the issue but I think it's related to this bug: https://bugs.archlinux.org/task/64321

Loading...