Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63202 - [cpulimit] update upstream to http://limitcpu.sourceforge.net/index.php

Attached to Project: Community Packages
Opened by DarcyHu (DarcyHu) - Monday, 15 July 2019, 13:59 GMT
Last edited by Balló György (City-busz) - Sunday, 01 September 2019, 08:04 GMT
Task Type General Gripe
Category Packages
Status Closed
Assigned To Balló György (City-busz)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Hey, it seems that the original upstream https://github.com/opsengine/cpulimit has no updated for 4 years. A new fork, https://github.com/opsengine/cpulimit, is available, and is actively updated. So, could we consider changing the upstream?
This task depends upon

Closed by  Balló György (City-busz)
Sunday, 01 September 2019, 08:04 GMT
Reason for closing:  Not a bug
Comment by Eli Schwartz (eschwartz) - Monday, 15 July 2019, 22:02 GMT
You referred to the same url again for the fork, but I assume the fork you mean is the sourceforge project?

From that page:

Update: Mr Marletta has re-launched his CPUlimit project, adding new features and improving OS X support. The new project is a re-write and should not be considered drop-in compatible with this project. The source code of the new CPUlimit project can be found on github. We here at the LimitCPU project will continue to work with downstream projects and with the resurrected CPUlimit project so that both projects may grow and improve.

Can you clarify why one might prefer one project over the other? Is there something missing or wrong in the currently packaged version?
Comment by DarcyHu (DarcyHu) - Tuesday, 16 July 2019, 07:28 GMT
Yeah, I mean the one from sf.net, it's a typo.
The one from sf.net provides more functions, for example, run in background/foreground, monitor children/forks process.
Or, maybe adding a new package limitcpu?
Comment by Balló György (City-busz) - Thursday, 29 August 2019, 19:20 GMT
limitcpu is a different project, you can install it from AUR:
https://aur.archlinux.org/packages/limitcpu/

According to the development log, I can't see too much activity:
https://sourceforge.net/p/limitcpu/code/8/log/

If it gets more votes, then I may replace it in the [community] repository.

Loading...