Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63201 - [deluge] std::bad_alloc

Attached to Project: Arch Linux
Opened by John Martelle (johnmartelle) - Monday, 15 July 2019, 12:34 GMT
Last edited by freswa (frederik) - Saturday, 22 February 2020, 21:33 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: When starting deluge, it terminates with the following error "terminate called after throwing an instance of 'std::bad_alloc'
what(): std::bad_alloc"



Additional info:
* package version(s) = 2.0.3-1
* config and/or log files etc.
* link to upstream bug report, if any

Steps to reproduce: Launch deluge from terminal.
This task depends upon

Closed by  freswa (frederik)
Saturday, 22 February 2020, 21:33 GMT
Reason for closing:  None
Additional comments about closing:  This seems pretty stalled to me. If it's still an issue, please fill a re-open request. Thank you :)
Comment by Stefan Schick (pommes_) - Saturday, 20 July 2019, 07:03 GMT
Hello John,

I am unable to reproduce, the issue. A std::bad_alloc error is related to memory allocation. Do you have enough memory available when starting deluge? Do you have any big torrents or something running inside the application which might take up a lot of memory?
Could you please provide your configuration, a log file if available and a stack trace for further investigation?
Comment by John Martelle (johnmartelle) - Saturday, 20 July 2019, 11:53 GMT
I have enough memory available, over 3 GB when starting deluge. I have no torrents running in the program and can't even click anything when the deluge screen does appear. Where exactly can I find the deluge config file or log files?
Comment by Federico (Synesthetism) - Sunday, 04 August 2019, 19:51 GMT
Same problem here.
I have big torrents placed in an external partition. When starting Deluge comes a system warning that the root partition space is empty. I think that this version of Deluge cannot remember the right path. I downgraded it and now it works well.

Loading...