Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63160 - [tipp10] Initial launch fails: database cannot be imported

Attached to Project: Community Packages
Opened by Don (TechnoJellyfish) - Thursday, 11 July 2019, 09:26 GMT
Last edited by Florian Pritz (bluewind) - Saturday, 31 August 2019, 07:40 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Florian Pritz (bluewind)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

The initial launch of a fresh installation of tipp10 fails with the following error message:

"Cannot find the database tipp10v2.templateThe file could not be imported.
Please check whether it is a readable text file.

(Error number: 203)

Affected directory:
/usr/bin/tipp10v2.template

The program will be aborted."

Presumably, it tries to create said database file on first launch but fails due to the lack of permissions in /usr/bin. It is not possible to change the location of the database file due to the program immediately exiting after throwing the error message. Each successive attempt to launch the program fails with the same error.

Additional info:
* package version: 3.0.0-1
* possibly related to this commit: https://svnweb.freebsd.org/ports?view=revision&revision=481328

Steps to reproduce:

1. Do a clean installation of tipp10
2. Run tipp10 for the first time
This task depends upon

Closed by  Florian Pritz (bluewind)
Saturday, 31 August 2019, 07:40 GMT
Reason for closing:  Fixed
Additional comments about closing:  tipp10 3.0.0-2
Comment by S├ębastien Viande (moiiom) - Tuesday, 30 July 2019, 12:24 GMT
Hi, i got the same error after a clean install.

I fix the error with the following commands:
mkdir $HOME/TIPP10
cp /usr/share/tipp10/tipp10v2.template $HOME/TIPP10/tipp10v2.db
tipp10

Loading...