Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63151 - Installer fails on ASUS TUF Gaming X570-plus motherboard-based system

Attached to Project: Arch Linux
Opened by Mike Dilger (mikedilger) - Wednesday, 10 July 2019, 20:33 GMT
Task Type Bug Report
Category System
Status Unconfirmed
Assigned To No-one
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

Description:

Cannot install Arch on https://bugs.archlinux.org/

New motherboard, new AMD Ryzen 7 3700X. Arch dated July 1st 2019 downloaded and verified and burned to USB. Boots into bootloader. Linux boots and outputs its initial messages. Once systemd takes over, all units rapidly fail. So many units fail so quickly that I cannot read the first error message (I tried about 10 times, just way too quick for my eyes).

Same behavior occurs if I take an existing updated Arch system and try to boot it on this new motherboard (that is actually what I did first).

Might apply to other x570 based motherboards, I cannot say.

Might be upstream issue with systemd, I cannot say. Debian 10.0.0 installer booted fine. I may be forced to switch to debian at this point.

Tried multiple bios settings including enabling/disabling secure boot, enabling/disabling CSM. Either it refuses to recognize boot media, or boots but creates this situation.

I wish I could supply log files or even the original error message. I know this isn't very helpful but I don't know how to get more data given the circumstance, and I thought someone should know.

Steps to reproduce:
Try installing Arch 2019-07-01 on an ASUS TUF-Gaming X570-Plus motherboard.
This task depends upon

Comment by Mike Dilger (mikedilger) - Wednesday, 10 July 2019, 20:35 GMT
Cut-n-paste error in the above. Should read "Cannot install Arch on ASUS TUF Gaming X570-plus motherboard-based system"
Comment by loqs (loqs) - Wednesday, 10 July 2019, 21:06 GMT
There is a bug in RDRAND on the new Ryzen chips. Systemd has been patched for the issue but you need installation media with systemd 239 as RDRAND support was added in 240 [1].
I would suggest trying the 2018.12.01 iso [2] as that should contain systemd 239.303-1 [3] the systemd package the installer will download from a mirror should be systemd 242.32-3 containing the patch.

[1] https://github.com/systemd/systemd/blob/master/NEWS
[2] https://archive.archlinux.org/iso/2018.12.01/
[3] https://git.archlinux.org/svntogit/packages.git/log/trunk?h=packages/systemd
Comment by Mike Dilger (mikedilger) - Wednesday, 10 July 2019, 21:17 GMT
Thanks loqs! I can now move foward, and it looks like this is well known.

Loading...