Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63140 - [wine] wineboot crashes with null pointer dereference exception

Attached to Project: Community Packages
Opened by Sergey Kvachonok (ravenexp) - Wednesday, 10 July 2019, 07:23 GMT
Last edited by Ivy Foster (escondida) - Friday, 11 October 2019, 20:36 GMT
Task Type Bug Report
Category Packages: Multilib
Status Closed
Assigned To Felix Yan (felixonmars)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Description:

After update to wine-4.12 wine reports a crash on startup like this:

wine: Unhandled page fault on write access to 0x00000000 at address 0x7fdd2775c235 (thread 000b), starting debugger...
000b:err:seh:start_debugger Couldn't start debugger ("winedbg --auto 10 24") (2)
Read the Wine Developers Guide on how to set up winedbg or another debugger

wineboot does not work correctly and does not update the mono and gecko packages on upgrade.

Steps to reproduce:

Run winecfg or wineboot.
This task depends upon

Closed by  Ivy Foster (escondida)
Friday, 11 October 2019, 20:36 GMT
Reason for closing:  Fixed
Additional comments about closing:  upstreamfixedit
Comment by Luc (iq2luc) - Thursday, 11 July 2019, 09:44 GMT
Comment by David Runge (dvzrv) - Saturday, 31 August 2019, 23:40 GMT
@ravenexp: Can we assume, that this is fixed now?
Comment by Ivy Foster (escondida) - Friday, 11 October 2019, 20:36 GMT
Bug reported fixed in wine 4.12.1; current wine: 4.17; OP contacted over a month ago for confirmation that update fixed it. Going to assume that it's fine, since upstream says so and no response from OP.

Loading...