Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63128 - [kbd] vlock utility is broken

Attached to Project: Arch Linux
Opened by Maxim (mxfm) - Monday, 08 July 2019, 13:45 GMT
Last edited by Jan de Groot (JGC) - Tuesday, 09 July 2019, 20:11 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

The vlock utility from kbd package is broken: after executing vlock it constantly reports authentification failure and prints its message again. There is no way to login back to console terminal, only to kill vlock. This utility didn't work for me at least since the beginning of 2019 (I forget to report this issue untill I faced it today).

Additional info:
* package version(s): kbd 2.0.4-2
* config and/or log files etc.
* link to upstream bug report, if any

Steps to reproduce:

1. Switch to console terminal and login.
2. Execute vlock.

The package was built at 2018-11-08, perhaps it needs recompilation due to changes in glibc.
This task depends upon

Closed by  Jan de Groot (JGC)
Tuesday, 09 July 2019, 20:11 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#61730 
Comment by Maxim (mxfm) - Monday, 08 July 2019, 14:20 GMT
The bug persists after rebuilding the package (not in clean chroot). Also the bug occurs when trying to lock from root account.

Seems to be a configuration issue - if I replace pam_deny.so with pam_unix.so at '/etc/pam.d/others', the program works as expected. Perhaps in previous versions the package contained pam.d settings?

Loading...