Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63117 - iwlwifi crash on Intel AC 9620

Attached to Project: Arch Linux
Opened by Edoardo Rosa (edoz90) - Sunday, 07 July 2019, 14:24 GMT
Last edited by Laurent Carlier (lordheavy) - Wednesday, 24 July 2019, 05:18 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Jan Alexander Steffens (heftig)
Laurent Carlier (lordheavy)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 18
Private No

Details

Description:

After the update of the kernel and firmware to versions 5.1.16 and 20190628.70e4394-1 the wifi card Intel ac 9620 stopped working: no connection, no detection from ifconfig and `SIOCSIFFLAGS: Input/output error` setting the interface `up`.

From dmesg I get:

```
[ 726.690785] iwlwifi 0000:3b:00.0: Collecting data: trigger 2 fired.
[ 726.690796] iwlwifi 0000:3b:00.0: Firmware not running - cannot dump error
[ 726.721213] iwlwifi 0000:3b:00.0: Applying debug destination EXTERNAL_DRAM
[ 726.844688] iwlwifi 0000:3b:00.0: Applying debug destination EXTERNAL_DRAM
[ 726.923128] iwlwifi 0000:3b:00.0: FW already configured (0) - re-configuring
[ 727.138117] iwlwifi 0000:3b:00.0: Microcode SW error detected. Restarting 0x0.
[ 727.138381] iwlwifi 0000:3b:00.0: Start IWL Error Log Dump:
[ 727.138382] iwlwifi 0000:3b:00.0: Status: 0x00000100, count: 6
[ 727.138383] iwlwifi 0000:3b:00.0: Loaded firmware version: 46.a41adfe7.0
[ 727.138384] iwlwifi 0000:3b:00.0: 0x00000071 | NMI_INTERRUPT_UMAC_FATAL
[ 727.138384] iwlwifi 0000:3b:00.0: 0x00A022F0 | trm_hw_status0
[ 727.138385] iwlwifi 0000:3b:00.0: 0x00000000 | trm_hw_status1
[ 727.138385] iwlwifi 0000:3b:00.0: 0x004882F2 | branchlink2
[ 727.138386] iwlwifi 0000:3b:00.0: 0x004793A2 | interruptlink1
[ 727.138386] iwlwifi 0000:3b:00.0: 0x00480E9C | interruptlink2
[ 727.138387] iwlwifi 0000:3b:00.0: 0x0001A7D2 | data1
[ 727.138387] iwlwifi 0000:3b:00.0: 0x00001000 | data2
[ 727.138388] iwlwifi 0000:3b:00.0: 0xE0000008 | data3
[ 727.138388] iwlwifi 0000:3b:00.0: 0x00000000 | beacon time
[ 727.138389] iwlwifi 0000:3b:00.0: 0x0003D679 | tsf low
[ 727.138389] iwlwifi 0000:3b:00.0: 0x00000000 | tsf hi
[ 727.138390] iwlwifi 0000:3b:00.0: 0x00000000 | time gp1
[ 727.138390] iwlwifi 0000:3b:00.0: 0x0003D67A | time gp2
[ 727.138391] iwlwifi 0000:3b:00.0: 0x00000001 | uCode revision type
[ 727.138391] iwlwifi 0000:3b:00.0: 0x0000002E | uCode version major
[ 727.138392] iwlwifi 0000:3b:00.0: 0xA41ADFE7 | uCode version minor
[ 727.138392] iwlwifi 0000:3b:00.0: 0x00000321 | hw version
[ 727.138393] iwlwifi 0000:3b:00.0: 0x18C89004 | board version
[ 727.138393] iwlwifi 0000:3b:00.0: 0x00230405 | hcmd
[ 727.138394] iwlwifi 0000:3b:00.0: 0x00022000 | isr0
[ 727.138394] iwlwifi 0000:3b:00.0: 0x00000000 | isr1
[ 727.138395] iwlwifi 0000:3b:00.0: 0x20001802 | isr2
[ 727.138395] iwlwifi 0000:3b:00.0: 0x404000C0 | isr3
[ 727.138395] iwlwifi 0000:3b:00.0: 0x00000000 | isr4
[ 727.138396] iwlwifi 0000:3b:00.0: 0x00230405 | last cmd Id
[ 727.138396] iwlwifi 0000:3b:00.0: 0x0001A7D2 | wait_event
[ 727.138397] iwlwifi 0000:3b:00.0: 0x00000000 | l2p_control
[ 727.138397] iwlwifi 0000:3b:00.0: 0x00000020 | l2p_duration
[ 727.138398] iwlwifi 0000:3b:00.0: 0x00000000 | l2p_mhvalid
[ 727.138398] iwlwifi 0000:3b:00.0: 0x00000000 | l2p_addr_match
[ 727.138399] iwlwifi 0000:3b:00.0: 0x0000000D | lmpm_pmg_sel
[ 727.138399] iwlwifi 0000:3b:00.0: 0x19062027 | timestamp
[ 727.138400] iwlwifi 0000:3b:00.0: 0x00001840 | flow_handler
[ 727.138613] iwlwifi 0000:3b:00.0: Start IWL Error Log Dump:
[ 727.138613] iwlwifi 0000:3b:00.0: Status: 0x00000100, count: 7
[ 727.138614] iwlwifi 0000:3b:00.0: 0x20000034 | NMI_INTERRUPT_WDG
[ 727.138615] iwlwifi 0000:3b:00.0: 0x00000000 | umac branchlink1
[ 727.138615] iwlwifi 0000:3b:00.0: 0xC008887A | umac branchlink2
[ 727.138616] iwlwifi 0000:3b:00.0: 0xC0084C80 | umac interruptlink1
[ 727.138616] iwlwifi 0000:3b:00.0: 0xC0080708 | umac interruptlink2
[ 727.138617] iwlwifi 0000:3b:00.0: 0x00000400 | umac data1
[ 727.138617] iwlwifi 0000:3b:00.0: 0xC0080708 | umac data2
[ 727.138618] iwlwifi 0000:3b:00.0: 0xDEADBEEF | umac data3
[ 727.138618] iwlwifi 0000:3b:00.0: 0x0000002E | umac major
[ 727.138619] iwlwifi 0000:3b:00.0: 0xA41ADFE7 | umac minor
[ 727.138619] iwlwifi 0000:3b:00.0: 0x0003D662 | frame pointer
[ 727.138620] iwlwifi 0000:3b:00.0: 0xC0886C44 | stack pointer
[ 727.138620] iwlwifi 0000:3b:00.0: 0x00230405 | last host cmd
[ 727.138621] iwlwifi 0000:3b:00.0: 0x00004008 | isr status reg
[ 727.138623] ieee80211 phy2: Hardware restart was requested
[ 727.138669] iwlwifi 0000:3b:00.0: FW error in SYNC CMD GEO_TX_POWER_LIMIT
```

lspci:

```
3b:00.0 Network controller: Intel Corporation Wireless-AC 9260 (rev 29)
Subsystem: Intel Corporation Wireless-AC 9260
Kernel driver in use: iwlwifi
Kernel modules: iwlwifi
```

ifconfig do not show the card while iw/iwconfig can be used to query/set the wifi card but `SIOCSIFFLAGS: Input/output error` only when trying to set the interface up.

Using an external WiFi dongle (AR9271 - ath9k_htc) I have no connection problem.
This task depends upon

Closed by  Laurent Carlier (lordheavy)
Wednesday, 24 July 2019, 05:18 GMT
Reason for closing:  Fixed
Additional comments about closing:  linux 5.2.2.arch1-1
Comment by Stephan Eisvogel (bsdice) - Sunday, 07 July 2019, 17:16 GMT
Same or similar issue on iwlwifi AC 9560. Issue is not the kernel but afaict a faulty firmware introduced with package linux-firmware 20190628.70e4394-1 by Luca Coelho.

Workaround: Downgrade to linux-firmware 20190618.acb56f2-1 and add linux-firmware in pacman.conf to "IgnorePkg = ..." line for the time being.

In my case firmware for wifi chip 46.3cfab8da.0 was good, 46.a41adfe7.0 is bad. Didn't test the intermediate version they put out.

https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/commit/?id=b44321804352ea595cddffbd8fad81a6c91c128d
https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/commit/?id=e58cbf78678fd872d0cf7ab858ba0030cd8695b0
Comment by Edoardo Rosa (edoz90) - Sunday, 07 July 2019, 21:40 GMT
I can confirm that downgrading linux-firmware the card works.
Comment by Albert Ferrero (aferrero) - Monday, 08 July 2019, 03:55 GMT
I can confirm. I also have Intel AC 9260 WIFI. Downgrading linux-firmware (20190628.70e4394-1 -> 20190618.acb56f2-1) resolved the issue for me.

*** EDIT ***
Just to add some more information on the issue.

This is the firmware that is loaded with the linux-firmware-20190628.70e4394-1 which DOES NOT work:
kernel: iwlwifi 0000:3b:00.0: loaded firmware version 46.a41adfe7.0 op_mode iwlmvm

This is the firmware that is loaded with the linux-firmware-20190618.acb56f2-1 which DOES work:
kernel: iwlwifi 0000:3b:00.0: loaded firmware version 46.3cfab8da.0 op_mode iwlmvm
Comment by Jefferson Ferreira-Ferreira (jecogeo) - Monday, 08 July 2019, 17:25 GMT
I can also confirm the bug and confirm downgrading linux-firmware as specified in last comments works. My card is Intel Cannon point-LP CNVi [Wireless-AC] (rev30).
Comment by Cédric Schieli (sdrik) - Monday, 08 July 2019, 18:54 GMT
Same issue here on iwlwifi AC 9560. Downgrading linux-firmware to 20190618.acb56f2-1 works.
Comment by Zdeno (bendo) - Monday, 08 July 2019, 19:10 GMT
Same issue here with Intel Corporation Cannon Point-LP CNVi. Downgrading firmware helped.
Comment by Cédric Schieli (sdrik) - Monday, 08 July 2019, 19:26 GMT Comment by Andreas Zweili (Nebucatnetzer) - Monday, 08 July 2019, 20:39 GMT
I'm experiencing the same problem with the Intel AC 9260 WIFI on a Dell Precsion 5530.
Reverting the linux-firmware package to 20190618.acb56f2-1 fixed it for me as well.
Comment by loqs (loqs) - Tuesday, 09 July 2019, 03:35 GMT Comment by Cédric Schieli (sdrik) - Thursday, 11 July 2019, 17:23 GMT
Issue still present with linux-5.2.arch2-1
Comment by loqs (loqs) - Thursday, 11 July 2019, 17:35 GMT
@sdrik what if you cherry-pick https://git.kernel.org/pub/scm/linux/kernel/git/kvalo/wireless-drivers-next.git/commit/?h=wireless-drivers-next-for-davem-2019-07-06&id=0c3d7282233c7b02c74400b49981d6fff1d683a8 ?
It appears to me to be the two patches you referenced combined and applies cleanly to 5.2.
Comment by Cédric Schieli (sdrik) - Thursday, 11 July 2019, 19:10 GMT
@loqs I didn't have time to test those patches until now.

I can confirm that cherry-picking https://git.kernel.org/pub/scm/linux/kernel/git/kvalo/wireless-drivers-next.git/commit/?h=wireless-drivers-next-for-davem-2019-07-06&id=0c3d7282233c7b02c74400b49981d6fff1d683a8 onto linux-5.2.arch2-1 does indeed resolve the issue for me. That is, I'm able to boot with linux-firmware-20190628.70e4394-1 and my Intel AC 9260 wifi adapter is working without any error in dmesg.
Comment by Cédric Schieli (sdrik) - Thursday, 11 July 2019, 19:14 GMT
For those interested, I'm attaching my PKGBUILD and the patch (one hunk needed to be adjusted).
Comment by Gustavo (pereiragc) - Monday, 15 July 2019, 22:29 GMT
Disclaimer: I'm not a developer or an advanced user, so I may be giving bad advice.

I had this issue during a fresh install in a recently purchased Asus Q326FA laptop. It was particularly annoying because even though the internet worked when the live usb was mounted, it stopped working once I booted into the installed system. Since that was a fresh install, there was no prior linux-firmware package in my pacman cache, so I had to boot back into the flash drive in order to access the internet and downgrade the package through svn.

I can confirm that downgrading to 20190618.acb56f2-1 solved my problem.

For those who run into a similar issue, a couple of things to keep in mind:
1) I didn't know how to properly downgrade a package to a specific version without the pacman cache. Following https://wiki.archlinux.org/index.php/Arch_Build_System#Checkout_an_older_version_of_a_package helped a lot.
2) Since you're probably going to run `makepkg -si`, make sure to follow the steps after you've arch-chroot'ed into the installed system and created a proper user with sudo privileges.
3) If you're doing this before setting up grub, keep in mind that after `svn update -r{356797} linux_firmware` and `makepkg -si`, the package `amd-ucode` is installed by default. So remove it before running the grub config tool.
Comment by Jefferson Ferreira-Ferreira (jecogeo) - Tuesday, 16 July 2019, 13:32 GMT
We have a new linux-firmware today, is the 20190712.d52556e-1. However, I've tested and can confirm the bug still exists. With this, we have two linux-firmware versions crashing iwlwifi. Continue ignoring linux-firmware updates until it's fixed.
Comment by loqs (loqs) - Tuesday, 16 July 2019, 17:50 GMT
@jecogeo has upstream indicated to you it will be fixed by a firmware update?
Comment by Jefferson Ferreira-Ferreira (jecogeo) - Tuesday, 16 July 2019, 17:54 GMT
@loqs Not sure. I've written to the package maintainer (Laurent Carlier) this morning getting his attention to this ticket and he immediately assigned the bug to him self on two others. It makes me think the answer is yes.
Comment by loqs (loqs) - Tuesday, 16 July 2019, 18:13 GMT
By upstream I meant Luciano Coelho luciano.coelho@intel.com the Intel developer that authored the firmware update and increased the FW API for the 9000 series to 46.
Or linuxwifi@intel.com / https://bugzilla.kernel.org Product:Networking Component:Wireless / The linux-wireless mailing list.
Comment by Cédric Schieli (sdrik) - Tuesday, 16 July 2019, 19:41 GMT
I can confirm that backporting https://git.kernel.org/pub/scm/linux/kernel/git/kvalo/wireless-drivers-next.git/commit/?h=wireless-drivers-next-for-davem-2019-07-06&id=0c3d7282233c7b02c74400b49981d6fff1d683a8 on top of linux-5.2.1-arch1-1 also fixes the issue with linux-firmware-20190712.d52556e-1.
Comment by Albert Ferrero (aferrero) - Wednesday, 17 July 2019, 05:17 GMT
No luck from me. I upgraded linux and linux-firmware:
[ALPM] upgraded linux-firmware (20190618.acb56f2-1 -> 20190712.d52556e-1)
[ALPM] upgraded linux (5.2.arch2-1 -> 5.2.1.arch1-1)

WIFI does not load, see following:
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: Firmware not running - cannot dump error
Jul 16 21:47:05 kernel: R13: 0000000000000000 R14: 00007ffd38c84480 R15: 00007ffd38c8447c
Jul 16 21:47:05 kernel: R10: 0000000000000000 R11: 0000000000000293 R12: 00007ffd38c8447c
Jul 16 21:47:05 kernel: RBP: 0000561b2c2d70e0 R08: 0000000000000000 R09: 0000000000000000
Jul 16 21:47:05 kernel: RDX: 0000000000000000 RSI: 00007ffd38c84320 RDI: 000000000000000a
Jul 16 21:47:05 kernel: RAX: ffffffffffffffda RBX: 000000000000000c RCX: 00007f3e1332b9fd
Jul 16 21:47:05 kernel: RSP: 002b:00007ffd38c842e0 EFLAGS: 00000293 ORIG_RAX: 000000000000002e
Jul 16 21:47:05 kernel: Code: 28 89 54 24 1c 48 89 74 24 10 89 7c 24 08 e8 ca ec ff ff 8b 54 24 1c 48 8b 74 24 10 41 89 c>
Jul 16 21:47:05 kernel: RIP: 0033:0x7f3e1332b9fd
Jul 16 21:47:05 kernel: entry_SYSCALL_64_after_hwframe+0x44/0xa9
Jul 16 21:47:05 kernel: do_syscall_64+0x5b/0x1b0
Jul 16 21:47:05 kernel: __sys_sendmsg+0x8a/0xe0
Jul 16 21:47:05 kernel: ___sys_sendmsg+0x316/0x380
Jul 16 21:47:05 kernel: sock_sendmsg+0x55/0x60
Jul 16 21:47:05 kernel: netlink_sendmsg+0x200/0x3c0
Jul 16 21:47:05 kernel: netlink_unicast+0x17a/0x200
Jul 16 21:47:05 kernel: netlink_rcv_skb+0x77/0x140
Jul 16 21:47:05 kernel: ? rtnl_calcit.isra.0+0x130/0x130
Jul 16 21:47:05 kernel: rtnetlink_rcv_msg+0x13a/0x3c0
Jul 16 21:47:05 kernel: rtnl_newlink+0x44/0x70
Jul 16 21:47:05 kernel: __rtnl_newlink+0x5b6/0x950
Jul 16 21:47:05 kernel: do_setlink+0x751/0xf20
Jul 16 21:47:05 kernel: dev_change_flags+0x32/0x70
Jul 16 21:47:05 kernel: __dev_change_flags+0x18e/0x1f0
Jul 16 21:47:05 kernel: __dev_open+0xe0/0x170
Jul 16 21:47:05 kernel: ? ieee80211_check_concurrent_iface+0x14f/0x1c0 [mac80211]
Jul 16 21:47:05 kernel: ieee80211_do_open+0x20b/0x840 [mac80211]
Jul 16 21:47:05 kernel: drv_start+0x3e/0x130 [mac80211]
Jul 16 21:47:05 kernel: iwl_mvm_mac_start+0x80/0x140 [iwlmvm]
Jul 16 21:47:05 kernel: __iwl_mvm_mac_start+0x183/0x290 [iwlmvm]
Jul 16 21:47:05 kernel: iwl_mvm_up+0x9ad/0xa40 [iwlmvm]
Jul 16 21:47:05 kernel: iwl_mvm_send_cmd_pdu+0x65/0x90 [iwlmvm]
Jul 16 21:47:05 kernel: iwl_mvm_send_cmd+0x2a/0x90 [iwlmvm]
Jul 16 21:47:05 kernel: iwl_trans_send_cmd+0x61/0xc0 [iwlwifi]
Jul 16 21:47:05 kernel: ? wait_woken+0x80/0x80
Jul 16 21:47:05 kernel: iwl_trans_pcie_send_hcmd+0x554/0x570 [iwlwifi]
Jul 16 21:47:05 kernel: dump_stack+0x5c/0x78
Jul 16 21:47:05 kernel: Call Trace:
Jul 16 21:47:05 kernel: Hardware name: Dell Inc. Precision 5530/066WMR, BIOS 1.11.2 05/29/2019
Jul 16 21:47:05 kernel: CPU: 2 PID: 700 Comm: NetworkManager Tainted: P OE 5.2.1-arch1-1-ARCH #1
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: FW error in SYNC CMD GEO_TX_POWER_LIMIT
Jul 16 21:47:05 kernel: iwlwifi 0000:00:1c.0: 00000020: 00000000 00000000 00000000 00000000 00000000 00000000
Jul 16 21:47:05 kernel: iwlwifi 0000:00:1c.0: 00000000: 14010001 00000000 00010000 00060011 00000000 00002000 00000000 00>
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: iwlwifi root port (0000:00:1c.0) AER cap structure:
Jul 16 21:47:05 kernel: iwlwifi 0000:00:1c.0: 00000020: ed40ed40 0001fff1 00000000 00000000 00000000 00000040 00000000 00>
Jul 16 21:47:05 kernel: iwlwifi 0000:00:1c.0: 00000000: a3388086 00100407 060400f0 00810010 00000000 00000000 003b3b00 20>
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: iwlwifi parent port (0000:00:1c.0) config registers:
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 00000020: 00000000 00000000 00000000
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 00000000: 14c10001 00000000 00000000 00462031 00000000 00002000 00000000 00>
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: iwlwifi device AER capability structure:
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 00000020: 00000000 0c040005 00000321 d55555d5 d55555d5 d55555d5 80008040 04>
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 00000000: 00489004 00000040 00000000 00000000 00000000 00000000 00027e1f 00>
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: iwlwifi device memory mapped registers:
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 00000020: 00000000 00000000 00000000 40108086 00000000 000000c8 00000000 00>
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 00000000: 25268086 00100406 02800029 00000010 ed400004 00000000 00000000 00>
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: iwlwifi device config registers:
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: iwlwifi transaction failed, dumping registers
Jul 16 21:47:05 kernel: ieee80211 phy0: Hardware restart was requested
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: Collecting data: trigger 2 fired.
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0x0BADCAFE | CNVR_SCU_SD_REGS_SD_REG_ACTIVE_VDIG_MIRROR
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0x0000485B | CNVR_SCU_SD_REGS_SD_REG_DIG_DCDC_VTRIM
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0x01300202 | CNVR_AUX_MISC_CHIP
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0x01000200 | CNVI_AUX_MISC_CHIP
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0xADF7F3B6 | FSEQ_CNVR_ID
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0x8ACD5728 | FSEQ_CNVI_ID
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0xADFB98DF | FSEQ_ALIVE_TOKEN
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0xF636C4C2 | FSEQ_TOP_CONTENT_VERSION
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0x0000A371 | FSEQ_OTP_VERSION
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0x4A26CA38 | FSEQ_CNVIO_INIT_VERSION
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0x00000000 | FSEQ_TOP_INIT_VERSION
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0x5A39B46D | FSEQ_ERROR_CODE
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: Fseq Registers:
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0x00004008 | isr status reg
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0x00240405 | last host cmd
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0xC0886C44 | stack pointer
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0x0003DDA5 | frame pointer
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0xA41ADFE7 | umac minor
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0x0000002E | umac major
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0xDEADBEEF | umac data3
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0xC0080708 | umac data2
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0x00000400 | umac data1
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0xC0080708 | umac interruptlink2
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0xC0084C80 | umac interruptlink1
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0xC008887A | umac branchlink2
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0x00000000 | umac branchlink1
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0x20000034 | NMI_INTERRUPT_WDG
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: Status: 0x00000080, count: 7
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: Start IWL Error Log Dump:
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0x00001840 | flow_handler
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0x19062027 | timestamp
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0x0000000D | lmpm_pmg_sel
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0x00000000 | l2p_addr_match
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0x00000000 | l2p_mhvalid
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0x00000020 | l2p_duration
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0x00000000 | l2p_control
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0x0001A7D2 | wait_event
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0x00240405 | last cmd Id
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0x00000000 | isr4
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0x404000C0 | isr3
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0x20001802 | isr2
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0x00000000 | isr1
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0x00022000 | isr0
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0x00240405 | hcmd
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0x00489004 | board version
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0x00000321 | hw version
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0xA41ADFE7 | uCode version minor
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0x0000002E | uCode version major
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0x00000001 | uCode revision type
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0x0003DDBE | time gp2
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0x00000000 | time gp1
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0x00000000 | tsf hi
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0x0003DDBE | tsf low
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0x00000000 | beacon time
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0xE0000008 | data3
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0x00001000 | data2
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0x0001A7D2 | data1
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0x00480E9C | interruptlink2
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0x004793A2 | interruptlink1
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0x004882F2 | branchlink2
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0x00000000 | trm_hw_status1
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0x00A022F0 | trm_hw_status0
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: 0x00000071 | NMI_INTERRUPT_UMAC_FATAL
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: Loaded firmware version: 46.a41adfe7.0
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: Status: 0x00000080, count: 6
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: Start IWL Error Log Dump:
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: Microcode SW error detected. Restarting 0x0.
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: FW already configured (0) - re-configuring
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: Applying debug destination EXTERNAL_DRAM
Jul 16 21:47:05 kernel: iwlwifi 0000:3b:00.0: Applying debug destination EXTERNAL_DRAM
Jul 16 21:47:03 kernel: iwlwifi 0000:3b:00.0 wlp59s0: renamed from wlan0
Jul 16 21:47:03 kernel: iwlwifi 0000:3b:00.0: Allocated 0x00400000 bytes for firmware monitor.
Jul 16 21:47:03 kernel: iwlwifi 0000:3b:00.0: Applying debug destination EXTERNAL_DRAM
Jul 16 21:47:03 kernel: iwlwifi 0000:3b:00.0: Detected Intel(R) Wireless-AC 9260 160MHz, REV=0x324
Jul 16 21:47:03 kernel: iwlwifi 0000:3b:00.0: loaded firmware version 46.a41adfe7.0 op_mode iwlmvm
Jul 16 21:47:03 kernel: iwlwifi 0000:3b:00.0: Found debug configuration: 0
Jul 16 21:47:03 kernel: iwlwifi 0000:3b:00.0: Found debug destination: EXTERNAL_DRAM
Jul 16 21:47:03 kernel: audit: type=1130 audit(1563338823.289:4): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=sy>
Jul 16 21:47:03 kernel: iwlwifi 0000:3b:00.0: enabling device (0000 -> 0002)



Downgrading the linux-firmware (and only linux-firmware) causes the Wifi to work:
[ALPM] downgraded linux-firmware (20190712.d52556e-1 -> 20190618.acb56f2-1)
Comment by Jefferson Ferreira-Ferreira (jecogeo) - Wednesday, 17 July 2019, 19:32 GMT
@loqs, this is really far beyond the understanding of the system I have. Do you think they must be notified? If yes, do you think you are keen to do it?
Comment by loqs (loqs) - Wednesday, 17 July 2019, 19:44 GMT
If upstream is not aware of the issue then unless the arch kernel maintainers choose to apply a patch to the kernel locally or the linux-firmware maintainer chooses to revert the firmware update
I would expect the issue to not be resolved until the release of 5.3 which http://phb-crystal-ball.org/ estimates will be Sunday, 2019-09-15.
I lack the hardware to provide any diagnostics upstream might require so I will leave it to those affected.
https://wireless.wiki.kernel.org/en/users/drivers/iwlwifi/debugging
Comment by Thibault Boyeux (tbw) - Sunday, 21 July 2019, 08:28 GMT
Same behavior with "Intel Corporation Cannon Point-LP CNVi [Wireless-AC]" controller

See this thread: https://bbs.archlinux.org/viewtopic.php?id=247599
Comment by loqs (loqs) - Sunday, 21 July 2019, 21:04 GMT
https://git.archlinux.org/linux.git/commit/?id=8dcd32438c96b8099b6447712148a4e4a06c78a7
Can those affected confirm the issue is resolved by linux 5.2.2.arch1-1 currently in testing?
Comment by Albert Ferrero (aferrero) - Sunday, 21 July 2019, 23:50 GMT
I can confirm, the linux 5.2.2 kernel that's in testing appears to work correctly when paired with the latest firmware package.


[ALPM] upgraded linux-firmware (20190618.acb56f2-1 -> 20190712.d52556e-1)
[ALPM] upgraded linux (5.2.1.arch1-1 -> 5.2.2.arch1-1)
[ALPM] upgraded linux-docs (5.2.1.arch1-1 -> 5.2.2.arch1-1)
[ALPM] upgraded linux-headers (5.2.1.arch1-1 -> 5.2.2.arch1-1)


[ 3.098854] iwlwifi 0000:3b:00.0: enabling device (0000 -> 0002)
[ 3.122654] iwlwifi 0000:3b:00.0: Found debug destination: EXTERNAL_DRAM
[ 3.122656] iwlwifi 0000:3b:00.0: Found debug configuration: 0
[ 3.122939] iwlwifi 0000:3b:00.0: loaded firmware version 46.a41adfe7.0 op_mode iwlmvm
[ 3.209509] iwlwifi 0000:3b:00.0: Detected Intel(R) Wireless-AC 9260 160MHz, REV=0x324
[ 3.225446] iwlwifi 0000:3b:00.0: Applying debug destination EXTERNAL_DRAM
[ 3.225631] iwlwifi 0000:3b:00.0: Allocated 0x00400000 bytes for firmware monitor.
[ 3.275082] iwlwifi 0000:3b:00.0: base HW address: XXXXXXXXXXXXXX
[ 3.362232] iwlwifi 0000:3b:00.0 wlp59s0: renamed from wlan0
[ 5.380894] iwlwifi 0000:3b:00.0: Applying debug destination EXTERNAL_DRAM
[ 5.507454] iwlwifi 0000:3b:00.0: Applying debug destination EXTERNAL_DRAM
[ 5.586005] iwlwifi 0000:3b:00.0: FW already configured (0) - re-configuring
[ 5.635117] iwlwifi 0000:3b:00.0: Applying debug destination EXTERNAL_DRAM
[ 5.764243] iwlwifi 0000:3b:00.0: Applying debug destination EXTERNAL_DRAM
[ 5.841657] iwlwifi 0000:3b:00.0: FW already configured (0) - re-configuring
[ 10.484965] iwlwifi 0000:3b:00.0: Unhandled alg: 0x707
Comment by Edoardo Rosa (edoz90) - Tuesday, 23 July 2019, 16:26 GMT
The issue is fixed for me also.
Upgrading the firmware to 20190717.bf13a71-1 and the kernel to 5.2.2.arch1-1 the module is loaded correctly:

[ 8.397589] iwlwifi 0000:3b:00.0: enabling device (0000 -> 0002)
[ 8.426139] iwlwifi 0000:3b:00.0: Found debug destination: EXTERNAL_DRAM
[ 8.426140] iwlwifi 0000:3b:00.0: Found debug configuration: 0
[ 8.426310] iwlwifi 0000:3b:00.0: loaded firmware version 46.a41adfe7.0 op_mode iwlmvm
[ 8.499859] iwlwifi 0000:3b:00.0: Detected Intel(R) Wireless-AC 9260 160MHz, REV=0x324
[ 8.511686] iwlwifi 0000:3b:00.0: Applying debug destination EXTERNAL_DRAM
[ 8.511823] iwlwifi 0000:3b:00.0: Allocated 0x00400000 bytes for firmware monitor.
[ 8.558599] iwlwifi 0000:3b:00.0: base HW address: aa:aa:aa:aa:aa:aa
[ 8.634538] iwlwifi 0000:3b:00.0 wlp59s0: renamed from wlan0
[ 9.024177] iwlwifi 0000:3b:00.0: Applying debug destination EXTERNAL_DRAM
[ 9.145944] iwlwifi 0000:3b:00.0: Applying debug destination EXTERNAL_DRAM
[ 9.222457] iwlwifi 0000:3b:00.0: FW already configured (0) - re-configuring
Comment by Thibault Boyeux (tbw) - Wednesday, 24 July 2019, 02:08 GMT
Latest firmware and kernel fixed it for me too, using the "Intel Corporation Cannon Point-LP CNVi [Wireless-AC]" controller

Loading...