Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63105 - [libheif] PLEASE ENTER SUMMARY

Attached to Project: Arch Linux
Opened by Nimrod Maclomhair (nimrod_mack) - Friday, 05 July 2019, 12:40 GMT
Last edited by Antonio Rojas (arojas) - Friday, 05 July 2019, 13:59 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To Antonio Rojas (arojas)
Christian Hesse (eworm)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

libheif supports building a gdk-pixbuf loader for heif which is not build/installed in this package. This seems to be because of missing depencies in the PKGBUILD file - having gdkpixbuf installed, the loader module is built and installed (using the very same pkgbuild file)

Simply adding gdk-pixbuf2 to the make depends should do it, I guess.

It would be great to have it built and installed however, to greatly smoothen the workflow for people dealing with iPhones. Thank you very much in advance!

Additional info:
* package version(s): 1.4.0-2
* integration of gdk-pixbuf loader first appears in version 1.4.0 (merge was done in commit 9d96532836d7b01a7288a22b81c77486f9885dbe)

Steps to reproduce:
- on a machine without gdk-pixbuf2 installed: build PKGBUILD, inspect pkg - no file "libpixbufleader-heif.so" has been built.
- on a machine with gdk-pixbuf2 installed: build the same PKGBUILD, inspect pkg - libpixbufloader-heif has been built.

This task depends upon

Closed by  Antonio Rojas (arojas)
Friday, 05 July 2019, 13:59 GMT
Reason for closing:  Implemented
Additional comments about closing:  libheif 1.4.0-3
Comment by Nimrod Maclomhair (nimrod_mack) - Friday, 05 July 2019, 12:45 GMT
Oh sorry! I forgot to edit the summary and now I seem to be unable to edit it. My bad! :/

Loading...