Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63097 - [deluge] python-cairo should be in deps

Attached to Project: Arch Linux
Opened by Anatoly Smaznov (javum) - Thursday, 04 July 2019, 12:27 GMT
Last edited by Antonio Rojas (arojas) - Thursday, 04 July 2019, 12:35 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: new version needs python-cairo package


Additional info:
* deluge 2.0.3-1

Steps to reproduce:
Run deluge? get error:

Traceback (most recent call last):
File "/usr/bin/deluge", line 11, in <module>
load_entry_point('deluge==2.0.3', 'gui_scripts', 'deluge')()
File "/usr/lib/python3.7/site-packages/deluge/ui/ui_entry.py", line 143, in start_ui
ui.start()
File "/usr/lib/python3.7/site-packages/deluge/ui/gtk3/__init__.py", line 58, in start
do_profile=self.options.profile,
File "/usr/lib/python3.7/site-packages/deluge/common.py", line 1344, in run_profiled
return func(*args)
File "/usr/lib/python3.7/site-packages/deluge/ui/gtk3/__init__.py", line 48, in run
gtkui = GtkUI(options)
File "/usr/lib/python3.7/site-packages/deluge/ui/gtk3/gtkui.py", line 201, in __init__
self.torrentdetails = TorrentDetails()
File "/usr/lib/python3.7/site-packages/deluge/ui/gtk3/torrentdetails.py", line 115, in __init__
from .status_tab import StatusTab
File "/usr/lib/python3.7/site-packages/deluge/ui/gtk3/status_tab.py", line 18, in <module>
from .piecesbar import PiecesBar
File "/usr/lib/python3.7/site-packages/deluge/ui/gtk3/piecesbar.py", line 20, in <module>
import cairo # Backward compat cairo <= 1.15
ModuleNotFoundError: No module named 'cairo'
This task depends upon

Closed by  Antonio Rojas (arojas)
Thursday, 04 July 2019, 12:35 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Read the optional deps

Loading...