Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63077 - [cura] 4.1.0-2 segfaults at startup

Attached to Project: Community Packages
Opened by Greg Darke (skunktrader) - Wednesday, 03 July 2019, 03:52 GMT
Last edited by Jelle van der Waa (jelly) - Tuesday, 06 August 2019, 16:03 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Jelle van der Waa (jelly)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description: I verified that cura started successfully when I installed the most recent update on 15 Jun 2019 23:45:28 AEST. I'm guessing one of the qt updates since then has broken it for me.

The stacktrace is:

Current thread 0x00007f8e18ede680 (most recent call first):
File "/usr/lib/python3.7/site-packages/UM/Qt/QtApplication.py", line 341 in exec_
File "/usr/lib/python3.7/site-packages/cura/CuraApplication.py", line 797 in run
File "/usr/bin/cura", line 136 in <module>
Segmentation fault (core dumped)

I solicited confirmation on the BBS and at least one other user has confirmed same issue:

https://bbs.archlinux.org/viewtopic.php?id=247454

Additional info:
* cura 4.1.0-2
python 3.7.3-2
xfce / qt / nouveau fully up to date

I did check through the upsteam bug reports at https://github.com/Ultimaker/Cura/issues but did not find anything that looked relevant.

Steps to reproduce:
Start cura
The UI flashes briefly on the screen then crashes
This task depends upon

Closed by  Jelle van der Waa (jelly)
Tuesday, 06 August 2019, 16:03 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in updated uranmium
Comment by Jelle van der Waa (jelly) - Wednesday, 03 July 2019, 07:24 GMT
I could reproduce the issue, but after much fiddling around this seemed to be resolved. My guess that it's related to cura's settings. But I will need to investigate further.
Comment by NA (Doctor_Propain) - Friday, 05 July 2019, 10:55 GMT
I am also having this issue. Jelly, would you mind telling what kind of fiddling you did to make it work again?
Comment by Jelle van der Waa (jelly) - Sunday, 07 July 2019, 08:22 GMT
Not really, I have the feeling it's due to the cura settings.
Comment by Stephan von Krawczynski (skraw) - Thursday, 11 July 2019, 11:16 GMT
You can startup cura if you delete the config file in ~/.config/cura/4.1/cura.cfg. But as soon as you enter the "St├╝tzstruktur" menu it crashes.
Comment by T Friedel (tomee) - Thursday, 11 July 2019, 11:17 GMT
I also had the issue, so I also tried fiddling with the config file as Jelle suggested. In ~/.config/cura/4.1/cura.cfg removing the categories_expanded entry fixed the problem for me. After some more fiddling it turned out that just removing the following entries within categories_expanded was also enough:

support
speed_layer_0
platform_adhesion
Comment by T Friedel (tomee) - Thursday, 11 July 2019, 11:25 GMT
When it runs again, you can disable some settings visibility as well to prevent crashes. I had to disable "Support Extruder" and "Build Plate Adhesion Extruder"
Comment by Stephan von Krawczynski (skraw) - Friday, 12 July 2019, 17:21 GMT
You can startup cura if you delete the config file in ~/.config/cura/4.1/cura.cfg. But as soon as you enter the "St├╝tzstruktur" menu it crashes.
Comment by Alexandre Oliveira (Xinayder) - Saturday, 13 July 2019, 22:00 GMT
I can confirm that this is still happening and it's probably related to plugins (segfault happens while trying to load some plugins).

This is my logfile: https://pastebin.com/LN6xGhbY

And I've reported the issue upstream: https://github.com/Ultimaker/Cura/issues/6008
Comment by Jonas Czech (Doohickey) - Sunday, 14 July 2019, 12:02 GMT
Removing the categories_expanded from the config file fixed it for me, but I also had to uncheck "support extruder" and everything under it in the settings visibility page, otherwise it still crashes when opening the "Support" submenu-page-expanding-thing
Comment by Alexandre Oliveira (Xinayder) - Monday, 15 July 2019, 00:14 GMT
It didn't work for me. It's something related to threading in python 3.7, triggered by the `_updateThread` method of `/usr/lib/cura/plugins/USBPrinting/USBPrinterOutputDeviceManager.py` and `/usr/lib/cura/plugins/RemovableDriveOutputDevice/RemovableDrivePlugin.py`
Comment by Alexandre Oliveira (Xinayder) - Monday, 15 July 2019, 17:06 GMT
One of Ultimaker's team member on GitHub commented on the GitHub issue I linked:

> The segfault for RockyTV is happening when the main window is loaded, not while the plug-ins are being loaded. Though granted, it's also complaining about missing dependencies during plug-in loading (libCharon and Zeroconf). Since it's happening while the main window is loading, it's most likely an issue with your version of Qt, i.e. not version 5.10 which we maintain.

I tried installing both python-libcharon and python-zeroconf and it still didn't work. Perhaps this is an issue with the current Qt version?
Comment by Jochum (jooch) - Wednesday, 17 July 2019, 22:08 GMT
Could anyone test Smplayer (also QT) with hardware decoding enabled? It's crashing on all my systems, except my laptop which is running Nvidia's propriety driver.
Either QT, or the open source video drivers are borked.
Comment by Jochum (jooch) - Thursday, 18 July 2019, 23:15 GMT
For me the solution was to entirely remove Cura and all related components (pacman -Rcs), purge cached packages (pacman -Sc) and update the system. Then install Cura again, any mismatch in libraries seems to crash Cura.
If Cura still crashes, you'll have to delete your Cura profile/cache too (great isn't it?). Profile data is stored in homedir/.cache, homedir/.config, homedir/.local/share.
Comment by Stephan von Krawczynski (skraw) - Friday, 19 July 2019, 07:32 GMT
This is _no_ solution as cura still crashes if you need the "Support" menu.
Comment by Moabit (Moabit) - Tuesday, 23 July 2019, 09:45 GMT
Upstream has proposed some patches to uranium that fix cura for me. The following amended PKGBUILD works for me.

# Maintainer: Jelle van der Waa <jelle@vdwaa.nl>
# Contributor: Grey Christoforo <first name [at] last name [dot] net>

pkgname=uranium
pkgver=4.1.0
pkgrel=2
pkgdesc="A Python framework for building Desktop applications."
url="https://github.com/Ultimaker/Uranium"
arch=('any')
license=('LGPL')
depends=('python' 'qt5-quickcontrols' 'qt5-quickcontrols2' 'pyqt5-common' 'python-pyqt5' 'python-numpy' 'arcus' 'python-shapely')
makedepends=('cmake')
source=("$pkgname-$pkgver.tar.gz::https://github.com/Ultimaker/${pkgname}/archive/${pkgver}.tar.gz"
'https://patch-diff.githubusercontent.com/raw/Ultimaker/Uranium/pull/500.patch'
'https://patch-diff.githubusercontent.com/raw/Ultimaker/Uranium/pull/499.patch')

sha256sums=('72245dba1fb74236144ffbe59497ef495b87bb3bb2b1d7ffcadebe138824eed4'
'd2d8c9acccfc59f906bfefe07d1683d363c65ac162a60c494acdebea121d9527'
'77cebd3742276ef585c8f93e7b942478e22abe1622ad6c1f0d1bd17d439fa3a5')

prepare() {
cd Uranium-${pkgver}
sed -i 's,/dist-packages,.${PYTHON_VERSION_MINOR}/site-packages,g' CMakeLists.txt
patch -p1 <"$srcdir/499.patch"
patch -p1 <"$srcdir/500.patch"
}

build() {
cd Uranium-${pkgver}
mkdir -p build && cd build

cmake .. \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release
make
}

package() {
cd Uranium-${pkgver}/build
make DESTDIR="${pkgdir}" install
}

# vim:set ts=2 sw=2 et:
Comment by OJ LaBoeuf (orangepeelbeef) - Thursday, 25 July 2019, 04:47 GMT
Confirmed Moabit's comment fixed the same issue for me.
Comment by Jelle van der Waa (jelly) - Sunday, 28 July 2019, 20:20 GMT
Applied and a new uranium is now in the repos
Comment by Stephan von Krawczynski (skraw) - Sunday, 28 July 2019, 21:11 GMT
I can confirm that the problem is gone when using new uranium from the repo.
Comment by Moabit (Moabit) - Monday, 29 July 2019, 01:25 GMT
Thanks @jelly

Loading...