Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63073 - [vim] please make new libcanberra dependency gvim-specific

Attached to Project: Arch Linux
Opened by Geert Hendrickx (ghen) - Tuesday, 02 July 2019, 18:07 GMT
Last edited by Levente Polyak (anthraxx) - Tuesday, 02 July 2019, 21:08 GMT
Task Type General Gripe
Category Packages: Extra
Status Closed
Assigned To Levente Polyak (anthraxx)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Vim package since 8.1.1614-1 requires libcanberra, which brings further sound-related dependencies like alsa-lib, libogg, libvorbis, sound-theme-freedesktop, ...

On servers this is considered unwanted bloat, vim is expected to be minimal. Can this dependency be made optional? (if it is useful at all?)

This task depends upon

Closed by  Levente Polyak (anthraxx)
Tuesday, 02 July 2019, 21:08 GMT
Reason for closing:  Implemented
Additional comments about closing:  8.1.1616-1
Comment by Eli Schwartz (eschwartz) - Tuesday, 02 July 2019, 18:21 GMT
  • Field changed: Summary ([vim] please make new libcanberra dependency optional → [vim] please make new libcanberra dependency gvim-specific)
  • Field changed: Status (Unconfirmed → Assigned)
  • Task assigned to Levente Polyak (anthraxx)
Sound support added to vim in https://github.com/vim/vim/commit/427f5b66ce0abe19daed9291b1693f6e8aae6552

I don't exactly get the point of vim being able to play sounds. :/

...

Regardless, this *cannot* be optional, since libcanberra is linked in and not dlopened, so it is all or nothing.

We usually compile programs --with-kitchen-sink where possible, so, IMO it makes sense to compile gvim with sound support. (If you're using gvim in a DE, you probably have it installed anyway...) However, I also think it is reasonable to ask people who want sound support to get it alongside their X11 clipboard and gtk3 UI support... and hence, this gripe should be retargeted at using --disable-canberra for the vim build (this is possible since https://github.com/vim/vim/commit/21606676d9ebc6f159c56ee90733e5d5720ab3d7 which made libcanberra able to be opted out of even when installed).
Comment by Geert Hendrickx (ghen) - Tuesday, 02 July 2019, 18:38 GMT
Fine with moving it to gvim, seems reasonable, for those users that want (literally) bells and whistles.
Base vim package should keep minimal dependencies.

Loading...