Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63065 - kmail not able to display emails

Attached to Project: Arch Linux
Opened by Christian Schaefer (chrisarcor) - Monday, 01 July 2019, 22:53 GMT
Last edited by Antonio Rojas (arojas) - Thursday, 04 July 2019, 21:31 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

Since 28.6.2019 (on up to date packages) Kmail is not able to display my emails. The preview pane just flickers...

When starting Kmail from the consol I get the following messages:
Use of deprecated not thread-safe setter, use setUrlRequestInterceptor instead.
WebEnginePage::javaScriptConsoleMessage lineNumber: 19 message: "Uncaught TypeError: Cannot read property 'compareDocumentPosition' of null"
QFSFileEngine::open: No file name specified

The last two lines are constantly repeated.

I tried to replace mesa packages, qtwebengine and intel vulkan driver but nothing helped. I don't really know if it is a packing bug or upstream bug.

The following process starts to use 100% CPU power...
/usr/lib/qt/libexec/QtWebEngineProcess --type=renderer --disable-in-process-stack-traces --disable-gpu-memory-buffer-video-frame


Additional info:
kmail 19.04.2-2


Steps to reproduce:
start kmail
on Konsole above error messages are displayed and QtWebEngineProcess starts to consume 100% CPU
This task depends upon

Closed by  Antonio Rojas (arojas)
Thursday, 04 July 2019, 21:31 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#63025 
Comment by Antonio Rojas (arojas) - Tuesday, 02 July 2019, 06:30 GMT
Does qtwebengine work at all? Try falkon or qutebrowser
Comment by Christian Schaefer (chrisarcor) - Tuesday, 02 July 2019, 21:29 GMT
Both browser are working.
Comment by Marc-Olivier Laux (marc-oliviermatlaux.net) - Thursday, 04 July 2019, 11:14 GMT
Hello,

just to confirm the exact same behavior on my Manjaro setup since last update : "Uncaught TypeError: Cannot read property 'compareDocumentPosition' of null", mail preview (and full view window) flickering headers and not displaying body.

At the difference that I have 2 IMAP accounts, and one is displaying mails correctly while displaying the message above.

On the 2 accounts, "not read mail" counts, in accounts folders tree pane, is not updating when viewing mails.



kmail --version
Attribute Qt::AA_ShareOpenGLContexts must be set before QCoreApplication is created.
kmail2 5.11.2

kontact --version
Attribute Qt::AA_ShareOpenGLContexts must be set before QCoreApplication is created.
kontact 5.11.2

qutebrowser seems to work properly.

While writing this comment, I found that it was in fact a pb with Akonadi/mariaDB DB upgrade related here :
`https://www.mail-archive.com/arch-general@archlinux.org/msg46428.html`

I fixed all the issues above by appllying the recipe :

# mysql --socket=/tmp/akonadi-USERID.XXXXXX/mysql.socket -e 'create database
mysql'
# mysql_upgrade --socket=/tmp/akonadi-USERID.XXXXXX/mysql.socket
# akonadictl restart
Comment by Antonio Rojas (arojas) - Thursday, 04 July 2019, 12:43 GMT
The QtWebEngine CPU usage doesn't point to the mysql issue. @chrisarcor have you performed the mysql upgrade?
Comment by Marc-Olivier Laux (marc-oliviermatlaux.net) - Thursday, 04 July 2019, 13:17 GMT
I didn't watch at the CPU usage sorry.
Maybe QtWebEngine CPU usage is just due to kmail looping in trying to redraw the mail content (the flickering) whereas it fails each time because of akonadi ?
Comment by Christian Schaefer (chrisarcor) - Thursday, 04 July 2019, 21:17 GMT
I did now the MariaDB upgrade and it works for me again also. I thought I did the DB upgrade before but probably I made some mistake... Before I saw Marc-Olivier's (thanks) comment I also tested Kmail with a (new) test account on the same machine and there it was working so I thought it had to do something with my kmail configuration...

I agree with Marc-Olivier that the CPU usage problem was probably due to kmail not being able to fetch the mail content and thus not being able to display it.

Loading...