Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#63028 - Steam : incorrect distribution name reporting due to missing lsb-release

Attached to Project: Community Packages
Opened by Robin Lange (Askannz) - Friday, 28 June 2019, 09:22 GMT
Last edited by Levente Polyak (anthraxx) - Wednesday, 21 August 2019, 21:48 GMT
Task Type Bug Report
Category Packages: Multilib
Status Closed
Assigned To Levente Polyak (anthraxx)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

Steam needs the lsb-release package to be installed in order to detect the distribution name correctly in its "System Information" report. If this package is not installed, Steam will report a generic "Linux (64-bit)" name.

Since lsb-release is not installed by default, a lot of Arch users unknowingly have this issue and it is causing headaches for databases which rely on the system info provided by Steam, like protondb.com or the Steam website itself : if you go to https://store.steampowered.com/hwsurvey/, you'll see that the second most popular distro is the generic "Linux (64-bit)" (although there may also be some snap/flatpak shenanigans going on here).

Suggestion : make lsb-release a dependency of the steam package.

Steps to reproduce:
Uninstall lsb-release, open Steam, got to Help->System Information, scroll down to "Operating System Version".
This task depends upon

Closed by  Levente Polyak (anthraxx)
Wednesday, 21 August 2019, 21:48 GMT
Reason for closing:  Implemented
Additional comments about closing:  1.0.0.61-2

Loading...